Wired Doorbell not picking up new wifi modem

I’ve a wired video doorbell - Video Doorbell Wired - it was working just fine for the past couple of years, no problems. But then I changed my wifi modem and now the door bell doesn’t work.
I’ve been through the set up to change network and when I get to the screen to select the wifi network your Ring Doorbell should use I get a blank screen. Only a message to say “Can’t find your network”.
I’ve tried forcing a full reset of the Doorbell by holding down the setup button for at least 20 seconds. And then following the instruction but I get the same result. No network found.
The wifi modem is fine and working as expected. Just the wired doorbell doesn’t see it nor any other wifi network for that matter.
How do I get around it?

Yep…I’ve been dealing with this ever since replacing my modem/router. There are several posts on here about the exact same thing, but no solutions. Someone posted that they used a newer phone and it was able to see the networks.

Hi neighbors. With network issues, there is typically no one-size-fits-all solution, as there are a lot of variables. I’d recommend reviewing this Help Center article, which covers the common troubleshooting steps to resolve issues during the setup process. Also, make sure the ports and protocols used by Ring devices are open on your network. If none of those troubleshooting steps work, please reach out to our support team at one of the numbers available here for more in-depth assistance. You can also get in touch with our support team on Facebook @Ring.

Since posting this question, I’ve created a ticket with Ring support.
There we went through all their typical troubleshooting techniques, and nothing has worked. They are sending that ticket to their “advanced technical department”. So I’m waiting to hear from them.

PeteK01, I’m sorry to hear about your experience. This doesn’t give me hope.

According to the Ring’s support pages my phone and OS should work just fine. It’s a Samsung A50 running Android 11. I’ll be seriously upset if I have to get a brand new phone just to get Ring to work.

My reckoning is that the latest upgrade to the Ring app is failing and only surfaces on a range of phones. Probably something was missed on testing the latest release before it went into production.

Anyway, not at all happy with Ring. All I want to do is reconnect the device I own to the modem I own. It should be pretty simple, right? But the app refuses to pick up ANY wifi modem. It would put you off getting any more products from Ring.

Good news! I’ve fixed this myself.

The trick is to uninstall the Ring app on your phone. It must be uninstall, remove will not do it for you. Once uninstalled, install the Ring app again.

Then you should be able to connect to all WiFi devices.

So, it was the app and not the hardware. Evidently upgrading your app will cause problems.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.