Wired cam saying battery low but no battery installed

I have an outdoor stick up cam wired to mains, is working fine, but saying battery is low even though no battery installed. Anybody else experience this?

1 Like

I do. I installed it yesterday. I am on the phone with Ring now trying to fuigure it out.

@moonbow According to Ring, I have a gen 3 wired cam (stick up), so it should have come with a battery. The indicator will not go away without the battery, but it will also not affect the operation, unless you lose power to the source. They are sending me a battery, maybe they will do the sam efor you. Good Luck.


I have a similar situation. The stand up camera is wired directly and does not contain a battery. Since the software upgrade, I have been getting a warning message about the battery being below 50%. The ring app will no longer allow me to display a live image. It directs me to a video to watch to charge the non-existant battery. I contacted Ring and was advised the engineers are working to resolve the issue. The only current work around is to install a battery to get the unit working again. I own a second camera with the same issues.


I installed two Ring cameras two days ago and intermittently had the same issue. Eventually I noticed that in the IOS app there are two different ways to bring up live view, one consistently works and the other consisently reports that live view is unavailable because the (non-existent) battery is low.

There are two attached screen captures. The one that has a blurry image at the top on a black background has a Live View timeline and a “Live” button that consistently works. The second screen capture with a white background and lots of controls has a red low battery symbol in the upper left and a dim “Live View” button that never works. If I scroll down that screen a little further I find a link that provides me with a video to tell me how to recharge the imaginary battery.

I suspect it’s the UI engineers and not the camera engineers who have some work to do.


We are aware of this and similar situations, neighbors. Thank you for bringing it to our attention. We have the team investigating and looking into it as well. We will certainly keep you updated with more information as it comes in. Thank you for your patience!

Is there a solution to this issue that came with a software update? I also just recently got the same issue they live is disabled due to low battery. It’s not low even if you go into settings it full, it’s wired with constant power.

For me it’s just a software issue. And I cannot reboot ring hence I cannot find this option in settings.

Hi @ErikH. I would suggest performing a reset on your Ring device, then reconnect it to your wifi. Doing this prompts an update on the device and should cause it to resume normal function. To perform a reset, press and hold the setup button for 20 seconds, then release. After the device reboots, reconnect it to wifi. The device will then perform a quick update and it should show the correct power source. Let me know if this works!

This looks a year old and it just happened to me after a power outage. I have reset the camera updated the firmware and it still doesn’t fix it. It didn’t come with a battery but has worked fine for 8 months.

Still having this issue. I have a battery stick up CSM running on a wire with no battery. Every time I reset and re-add the camera to my app it does the same thing. 15 minutes of updating firmware, app suggests switching camera to battery mode, I deny it. It keeps asking and eventually forces it into battery mode. Then it shows this when I try to view it live.

Ring, you need to fix this. You’re taking our money yet failing to deliver a functioning product and it’s been going on for over a year.

1 Like

I am having this same issue Jirene, and according to their website Changing power modes on your Ring Stick Up Cam (3rd generation) – Ring Help
You should be able to run it. I just bought a two 3rd gen stick up cams with battery/solar support. and according to that article clearly i should be able to run them both with JUST the power cord…

1 Like

I have the same problem. Just noticed it for the first time today.
It’s a wired camera without a battery and had it around a year with no problems.
It still records motion triggered video, but won’t show live feed due to non-existent low battery.
I see a message from Ring from almost a year and a half ago saying they’re working on it. Really?

Seems to be an issue with the app rather than the camera; I get the “battery low” warning on iOS app and am unable to view live, but if I log into the website I can view live without any problem at all, and no warnings.

I’m getting this now after only a month of running my new gen-3 stick up cam. No issues with my other battery powered one.

Can’t believe this has existed since May 2020 and still no fix by Dec 2021.

Same problem, 2 cameras,no live view,getting 2 new ones. Tried resetting number of times

Same problem. Supposed to get 2 new cameras. Feel we have been taken

We’ve seen many neighbors share success with checking the power adapter connections are secure and that any adapter ports are clean of debris. Please ensure you are using the included or proper power supply as well.

Check out also, our Help Center article about changing power modes, to ensure the proper power settings are selected.

For further troubleshooting, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

It’s now June 2022 and this is still occurring. My security camera has not been recording for a month now and when I rang Ring support, they say the camera is faulty. It’s out of warranty so they’ve offered me a 30% discount on a new camera but if this is a known fault, I feel I’m being taken for a ride. Is there anyone I can email to make a formal complaint?

I found another thread where they closed this same issue. Thing is, we are still getting this issue.

My wired camera says low battery. I bought this specific one so I wouldn’t need a battery.

I contacted ring and they are sending me another saying this one is faulty.