Windows App - can no longer delete multiple selected videos.

Recently the Ring app has stopped letting me delete multiple selected videos from history. I am able to click Select in the upper right of the app screen and checkboxes appear as expected next to each video. The checkboxes work correctly letting me select multiple videos. Then clicking Delete in the upper right corner gives the expected warning that a number of videos will be permanently deleted. However when clicking on OK, the progress indicator at the top of the Ring app runs, then stops, but the selected videos are not deleted. I can delete videos individually by right clicking a video and selecting Delete, but with three devices and several false triggerings from wind, etc every day it is incredibly annoying to not be able to clean up useless videos in batches.

1 Like

I have the same problem. It started either today or yesterday. I am using a laptop with Windwos 10. I suspect it has something to do with the change in the program that excludes deleting starred items with SELECT.

1 Like

I have same problem with selective delete. Found a delete all in menu, but using this foces me to delete everything unles I delete 1 by 1 by viewing the trash canning what was watched. I miss the old way.

1 Like

Hey neighbors! I’m sorry to hear you’re having trouble deleting multiple events at once on your Windows 10 app. Rest assured that our team is investigating and working to resolve it as soon as possible. In the meantime, feel free to use your mobile app to manage your event history to delete more than one at a time, or utilize the delete all feature! :slight_smile:

Thank you for this information, neighbors. For now, I have accepted this post as a solution. While we are aware of this concern and as the team continues to investigate, this is a helpful way for other neighbors that come into this thread to try these recommended steps. Please feel free to share in depth information and examples as to what happens so we can pass it along to the appropriate teams, including your Window’s OS and app version as well. We appreciate your patience and will continue to update this thread with more information. Thank you.

same problem

I’m sorry, but this is a pretty shabby answer to be called a “solution”. Telling us that we should just suck it up and that’s how it is now is lousy customer support. You have disabled a feature I made extensive use of in the past and, since there is no way to acquire a standalone installer for a windows application for Ring, we are at the mercy of this new trend towards “Apps” (not applications) that do as they please whenever they please. Sorry for venting but this is more iritating than I can express.

1 Like

@blue_gascon No worries! I appreciate your feedback on this situation and I can assure you that our team that looks into issues with the Windows app is investigating this concern for us. These things can take some time, but I promise to give you timely updates as soon as I have them. I really do appreciate your thoughts and concerns on this, as we value the neighbor’s experience and want everything to be smooth sailing for everyone. I’ll make sure to keep this thread updated accordingly once we reach a resolution!

I am having the same problem as above and it is very frustrating!

Just to be clear here, I DID NOT accept this solution! You arbitrarily marked this as solved when NOTHING has been done. I was basically told “that’s the way it is now, we’ll look into it.” Pardon me, but that IS NOT a solution. I sure won’t hold my breath waiting for a real solution. If I look for additional cameras I’ll be giving the NEST cameras a serious look. Meanwhile I am stuck with a product that has had a very useful featue disabled by the manufacturer with little hope for a true remedy.

1 Like

I have the exact same problem and it happens on:

desktop with WIN 10 home

laptop with WIN 10 prefessional

phone with Android

since I have about 30 false alerts each day because of wind, the history is piling up and I am overloaded with videos that need deleting ASAP.

I cannot understand what has happened and why this option would be eliminated. There is NO way I am deleting 400-500 videos one ay a time.


1 Like

mobile app also is broken–it will NOT delete multiple selected videos at 1 time

who is programing the changes and updates to Ring apps?? Amateurs??

there is NO way right now to delete these annoying videos

@purplegolfchic Could you please attach a screen recording of what happens when you try to delete the events by more than one at once? While this functionality is limited on the Windows 10 app at this time and is something that is being worked on by our teams, this functionality should still exist if you have the most up to date Android or iOS app on your mobile phone. If you go into the Main Menu > Devices > Device with events to manage > Event History, you will need to click edit at the top right or slide to the right on the event list, in order to pull up the little clickable bubbles to the left hand side.

Let me know how this goes and screen recording if it continues to not work! You can zip the screen recording into a zip file (normally right clicking on the video file and then selecting “compress”), as you can attached a zip file to your reply!

I’m having the same probelm in the Windows 10 App. I can select mutliple items, then choose to delete, but it just spins and spings and does not delete. The “solution” to use a mobile app or the web page is a work around, but really need the bug fixed in the Windows 10 app.

I have been having the same problem the past 2-3 weeks with not being able to delete multiple history events. Very frustrating having to delete one at a time which is not acceptable. What changed?

Hey neighbors! It looks like we release a fix for this on Monday, and confirmed it to be working as it should today. If you could, please test this and verify that it is working for you. :slight_smile:

I just tested this out and it seems to be functioning correctly again. NOW it can be considered resolved.

1 Like

I’ve had the same frustrating problem lately with not being able to delete multiple history events on my PC unless I deleted one event at a time. I don’t know if this will help you but yesterday I tried deleting multiple history events on my PC, had the same problem, and then tried using my IPAD to delete multiple history and it worked. I then went to my PC and tried deleting additional multiple historyevents and it worked. It worked again today on my PC. I have no idea why it is now working but it is.

1 Like