WiFi Problem Completely Baffled

I have a brand new Video Doorbell 3. The model number is 5AT359. When I try to connect it to our WiFi, I end up with white lights blinking on the right side of the ring. I did the usual troubleshooting. I am entering the correct password and tried it right next to the access point. Signal strength is fine. We have numerous Alexa-enabled devices, video games consoles, Smart TVs, laptops, desktops etc. on the network, and they all work fine. The WiFi device is from Xfinity. It is also a modem and carries the brand name of Technicolor. It is only six months old. When I tried to connect the Ring device to the my cell phone’s hot spot, it connected fine so the problem is not the door bell, but this is not ideal. Does anyone have any theories as to why it will not connect to our WiFi? Thank you.

Hi @sthomas416 I had a similar problem.
1st time I connected perfect. Over a few days it dropped out and I couldn’t connect.
It wouldn’t connect anywhere in the house.
In the end did a full reset no joy but by this point I had purchased a chime Pro so tried connecting through that.
Connected 1st time and has been fine since then.
Never did find out what the issue was but have a replacement bell on the way due to water damage so will let you know if it connects or not.

Please let me know if the replacement works. I am wondering if the router has a limit as to the number of MAC addresses it can handle. I am going to try researching it on the Xfinity side

Hi @sthomas416. A right flashing white light indicates that your phone is unable to connect to the Ring Access Point. First, make sure that your Ring Doorbell is in setup mode (Spinning White Light). Next, make sure that your wifi assist/network smart switch and bluetooth is turned off. Also, make sure any wireless printers or baby monitors are unplugged while attempting setup, as they may be causing interference. This should allow your to connect to the Ring Doorbell after you perform a reset on it. You can perform a reset by pressing and holding the setup button for 20 seconds, then releasing. I hope this information ie helpful.