Wifi on Alarm System Base Station not working. (Gen 2)

I’ve just bought the Alarm System Gen2, and the base station will NOT connect to wifi. Every time I select my network, and enter my wifi password, an error message pops up and tells me “Wifi Connection Error”.

I’ve tried everything from resetting my routers, network, and even factory resetting the alarm base station. Nothing works.

Because of this issue, I’ve had to use the ethernet connection instead of wifi. The ethernet connection works, but it isn’t very convenient. I’ve continued to set up the Alarm System, but the Wifi still doesn’t work.

Is this an issue with the newer 2nd gen alarm systems, or is it because my base station is faulty?

2 Likes

Hi @JonathanLin! I recommend testing your other Alarm sensors, as well as cellular backup if you are subscribed to a Protect Plus plan. This will confirm that all the communication protocols are working on your Base Station. The next best step will be to check any router settings or unique security protocols you might have enabled on the network.

If the wifi setup still does not complete, the best next step will be to reach out to our support team for a more in-depth look at this. :slight_smile:

I’m having the same issue with my new base station. Works on Ethernet but refuses to connect to my Verizon router over WiFi even sitting right next to it. Did you ever find a resolution to this?