Wifi not connecting on bridged network

I know this is not a new topic however I have tried a zillion different suggestions and none work so far. I just got a new internet gateway from Verizon. If I hook up ring directly to it, I have no issues. The problem is I am using my Netgear router as the Verizon gateway did not do well with multiple devices connected to it. The Netgear cleared up that issue but I can not get any of my ring cameras to connect.

I get through set up mode fine. It connects to my stick up cam.
When it asks to connect to wifi - it says connecting to wifi just a moment…then it hits 95% and says still connecting. After a minute or so it finally says set up did not complete check your internet connection and try again.

Some things I have tried:
Turning on/off mobile data, turn on/off switch to better wi-fi networks, on my Samsung S23 Ultra
Trying with my work phone iPhone 11
changing router to display both 2.4 and 5 (turned off smart connect)
enabled/disabled AX on router
reset both Verizon Gateway and Netgear Router to default and started all over again
Made sure SSID match
Tried connecting on a specific channel
Turned off beamforming
Set a static IP for the Ring camera
Enabled/disabled traffic meter

These are some of the things I tried! Please any help with using Verizon Gateway bridged to Netgear RAX50???

Hi @user56505. Those were excellent troubleshooting steps to try for your concern. You should also review this Help Center article to see if there are any other settings on your router you would need to change. If you have tried this step and are still having the same concern, give our support team a call for further assistance.

This may be of interest regarding your problem (just posted)…

Flawed camera automatic update prevents Hotspot connectivity