Whole system down

So i have had 2 ring doorbell pros hooked up for 3years and no issues. I decided to buy 2 new ring doorbell pros just to replace older worn ones. Hooked them up and no power. Check power and it was good but decided to go ahead and buy new transformer from ring the 16v 30vac. Installed and system came up without issue. After about 2 hrs the mechanical chime melted. So i tried bypass with power kit v2 still no power. Checked voltage at transformer and its still good. Connected rings back and no power at transformer. Disconnected ring and have power at transformer again. What is issue?

Hey @Urtek16. Did you not install the Pro Power Kit V2 when you first installed the Pro? The Pro Power Kit is needed for every single install of the Doorbell Pro, as it regulates the power. If this is not installed, this could be why it caused this concern for you, as it sounds like you installed it after the fact. If you have not already, as soon as you possibly can, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.