White Flashing (Left) Light.

My original Ring doorbell has worked for years and only recently have I had trouble.

I am running on a wifi connection and, as I’ve done for years, the last time the battery went flat, I removed and charged my doorbell.

Reconnecting it to my wifi, since this last recharge, has been an absolute nightmare. Password is correct and the signal is strong. I purchased a wifi extender to ensure a stable connection (even though I’d been using the doorbell for years without an extender).

During set-up, the wheel spins and the temporary Ring network appears and connects successfully. It asks me to choose a wifi network and I enter my password. That’s as far as I get. This happens across 3 different devices.

I have spent the last 3 months trying to reconnect. I have hard reset the doorbell more times than I can count. I have read and tried every remedy mentioned online, over and over again, but nothing has worked.

Is it possible to brick these devices? I am at my wits end and about 2 failures short of throwing my doorbell against the wall.

Any help appreciated.

I guess I’ve got an expensive paperweight…

Hey @EStone30. I know you have down the bulk of the troubleshooting possible, and appreciate your effort to fight the good fight in seeing if you can have your Doorbell reconnect and work as it once was. Have you been able to reach out to our support team on this concern at all? They can deem if your device is no longer functional, or see if they can get it working for you! If you do call, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Please let me know what the outcome is for you!

Ok I spent hours trying g to get this device to connect , I been on the phone with ring , they transferred me to a specialist who told me it could be my WiFi and to try and connect it to a different network. I drove it to my cousins house and tried there and it did the same thing . I can not believe ring offered to sell me a new device ! If I can not get this device to work and ring will not assist I will take to social media and let people know that the story

I’m having the same issue and its maddening

Hi @Billboackfin. Did you follow up with support after testing on a secondary wifi network? A left flashing light indicates that there is a network issue. You can also try connecting to a wifi hotspot to see if that changes how the doorbell connects. Feel free to let us know how our support team is able to assist you once you’ve contacted them again.