Video playback

i am unable to watch any recorded videos using the Apps?

I have tried on 2 phones and on the PC. to make sure it is not the network i have tried both phones using their data plan which are on different networks.

The app works on all 3 devices to watch live videos on demand and also when a notification pops up so there is no issue with connecting to the app?

all videos just go through a buffer issue where is will only play 1 or 2 seconds of the video then stop for 30 seconds?

Any ideas?


This is odd to hear of @Pooley. The best first step will be to remove and reinstall the application on your mobile device. Please also ensure VPN is disabled on any mobile devices you are using. It sounds like you are able to see some of a recording, but if you are completely unable to access recordings please confirm your Protect Plan subscription is active for recordings to save.

Great call checking on your mobile device connection variables! I recommend also double checking on your wifi signal, or RSSI in the Ring app device health section. This will ensure for the best delivery of recorded videos. With live view working well, this is a good sign that wifi is likely sufficient, however, it’s always good to confirm. I hope this helps! :slight_smile:

Hi there,
The RSSI does not really make a difference as this is only the connection the Wifi extender.
The problems seems to have sorted itself out since I posted, you answered this post, but it was a strange situation that was causing a buffering before payback. It was like watching netflix through dial up. It was painful.
Anyway, thanks for the reply and suggestions.

1 Like