Video doorbell2 Live View "Not Working" Samsung Galaxy S10

This absolutely worked for me.Thanks so much.


Not just Samsung wont work on my Xperia 1 either.Must just be an Android 10 issue ,worked flawless on android 9 ?

You are a life saver, I was about to send my Ring back as it was consuming myself with the fact that I knew it was only a matter of switching something off. It is all working now. Cheers.

1 Like

Mate, for the time being you have to have a second app if you still want to use your bluetooth on, the app is called Rapid Ring. Whenever you want to have the live view you open the Rapid Ring isntead and voila! One thing that I found out here (I am on android) and could be usefull as well is that in order to the live view to work I had to switch off the data saver.

Try switching the data saver off.

@Ktmimi wrote:
The only solution that worked for me was turning off the data saver.

You are a life saver, I was about to send my Ring back as it was consuming myself with the fact that I knew it was only a matter of switching something off. It is all working now. Cheers.

1 Like

Data saver off still does nothing.Was a android 10 update last week then it worked again,a day later was a ring app update then it stopped working again ? Tried the rapid that’s doesn’t work.

Reset network settings

Tried that,worked flawless till I moved to android 10

I just realized that many of these issues are directly related to how Ring connects to your phone when you try to connect one of THIER devices.

Ring connections connect to your phone as an ACTUAL call. Your phone think it’s making a call and if you have a Bluetooth device connected it will try to reroute the call to your device via Bluetooth. This is why turning OFF Bluetooth or disconnecting from your watch fixes the issue.

I also realized that if you pull up a device in your car that has a Bluetooth hands free connection, the audio will route as a call, NOT media audio.

My Jeep will not allow me to makes calls if I did not 100% close the Ring app. It’s says “Cannot complete this function while On a Call”. What?

In my wife’s Nissan, if she checks a notification, the rear entertainment system audo will terminate because it thinks it’s on a CALL. I couldn’t figure out why for the life of me the Rear Entertainment system kept losing its audio. Now I close the RING app and then force shut it down in the phone system menu and the audio would return to the car.

I have resorted to disconnecting my Samsung watch and keeping Bluetooth off on the phone. I can no longer use hands free or Bluetooth.

But that doesn’t matter because… Even with Bluetooth OFF, the Ring app will connect to the device and send the audio to the phones EARPIECE, just like a call. This only used to happen 1 out of 10 connections. But after Android 10, it happens 1 out 5 times.

I have to force close the RING app to get the audio back to my phone’s speaker.

RING is near dead to me. I can’t believe this forum is nene going on this long and not a SINGLE Ring rep has replied.

Hey neighbors! Thank you for working together, and sharing your experiences with recent android updates and the Ring app. We will be sharing this feedback with the appropriate teams for further investigation.

If you are still experiencing live view concerns, please try the following:

  • Ensure your signal strength is sufficient. Check out our Community post about RSSI for tips on optimizing signal strength.
  • Test live video on wifi only, and on cell data only, on your mobile device.
  • Remove and reinstall the Ring app on your mobile device.
  • Check for any Android apps that might conflict with the Ring app.
  • Disable bluetooth, VPN, data saver and close any apps that might conflict with processing or connection on your mobile device.

After completing the above steps, if live view is not connecting as intended, try our Rapid Ring app which is designed to connect to live view quickly. Feel free to keep us updated with any further observations!


Could you please tell us why Bluetooth has to be off to make our live view video and audio connections work correctly?

Are you saying that we can not use Bluetooth on our mobile devices if we want Ring devices to work correctly?

Hello, everyone. I was so excited to buy the ring doorbell and could not wait to start building my ring products kingdom so to speak.

i bought the doorbell system and paid best buy to install it, after all that, my newer phone, Galaxy Samsung S10 phone would not work the minute I left my house internet, when ever I would leave the house internet, drive away in my car, that was it not ring notification, so whats the point in having the ring when you can’t see whos at your door while away? funny thing is, it worked just fine on my Grandsons older iphone. I spent the entire day with Ring support, Samsung and best buy install team. They report its a samsung problem, No success, they told me to buy a new phone, of which is out the question, this one is new.

same thing, I spent the entire day on the phone conference, ring samsung, no success.

Ring should fix this ASAP. Anyone with a smartwatch with audio capabilities has this issue. I have to disconnect my watch just to answer the doorbell… Fix it Ring!

have a Samsung Note 9 … running Android Version 10 on the Note 9 …Live View will NOT connect as long as Bluetooth is TURNED ON for my Galaxy Watch… I turn Bluetooth off and Live View Connects… will RING fix the problem… probably NOT

I have the same issue with mynew Galaxy s10e phone…it worked fine with my old Galaxy 7, but work upgraded us to the new S10e and it won’t show. I can see it fine on my computer, but not with my new phone. Come on RING, fix the issue. You have to know it is a problem.

“Test live video on wifi only, and on cell data only, on your mobile device.”

This is what worked for me (Samsung Galaxy s8). It DID NOT work when I switched to wifi only, but it DID work when I switched to cell data only. I turned wifi back on and I’m good to go. It is now working again with either wifi only, cell data only, or both.

(I rarely use bluetooth. Mine worked fine until it errored a few days ago only a couple of times, and then errored all the time starting 1 or 2 days ago. I had an adroid update in that timeframe, so maybe something there caused it.)

Nevermind. Problem not really solved. It stopped working again. Some phone restarts and toggling to data only eventually worked (took a few tries). Annoying. I think the android update caused this. I’ll probably dig in more later, but this is the kind of stuff that should “just work”, because it is the essence of what this product is. Disappointing :frowning:

Yes, I have a Galaxy S9, after an android update, Ring stopped working. I can’t get Alexa to discover the Ring device.