Video Doorbell Pro - Worked for 5 minutes then quit

I just installed the wired Doorbell Pro (refurbished directly from Ring) and it worked perfectly for about 5 minutes. All of a sudden the WiFi connection dropped and now my Iphone won’t connect to the Ring WiFi network during the setup process. I’ve read through at least twenty different topics related to this issue and I’m just adding mine to the pile in hopes that someone can help me. I’ve done the reset (20 seconds) and the white light on the front is circling but my phone won’t join the Ring Wifi network. What a pain.

Hi @MikeBrantley1982. There are multiple troubleshooting steps you can try in order to connect to the Ring network:

  1. Reboot your Apple device (shut down completely and then power on)
  2. Adjust the Smart Network Switch on your Android phone
  3. Make sure your battery is fully charged if you’ve attempted set up multiple times during a first time set up. (Batteries are not shipped with 100% charge because of legal regulations.)
  4. Try setting up on a different mobile device (another mobile phone or a tablet)
  5. Check Apple Wi-Fi Settings. (Go to Settings on your mobile device, then to WiFi. Make sure Wi-Fi is toggled on. Under Ask to Join Networks, choose Ask.)

You can find more troubleshooting tips for when the in-app setup isn’t working in our Help Center Article here. I hope this information helps! :slight_smile: