Video doorbell pro no worky

Tried to connect my doorbell to my new WiFi and am failing miserably… White circle is spinning, but when I get to the point where you press Join and the doorbell is supposed to connect to the phone it says Unable to Connect… After about 3 times, it sends me to my phone settings where the Ring WIFI sometimes shows up, but it either fails to connect or, rarely, does connect but then the connection is instantly terminated… Tired removing device from my APP and factory resetting, but after scanning the QR code it gets to the same step as above and fails… Tried turning phone off/on, tried rebooting the router (but we never get to that step, so can’t really be it)… Oh, Local Network is turned on for the Ring app, it had me check that

Hi @FCTejas. Those were excellent troubleshooting steps to try for your concern. I would also recommend making sure the Ring app and your phone are up-to-date with the latest updates available. If that doesn’t help, try using a different phone or tablet to complete your setup. We also have this Help Center page with other steps to try to address your concern. I hope this helps.