Video Doorbell Pro Dying

Tried resetting Doorbell Pro several times. Do not get any light, spinning or otherwise, white or blue. Power is good, internet is good, other devices work fine. No alerts, no video from doorbell. If I push the main button on the doorbell only the doorbell itself rings as does the mechanical doorbell. Two techs couldn’t figure it out. One even sent me a new doorbell! Initial setup worked fine but two days later it died. Very frustrating!!

Hello @philG, it sounds like you are having concerns with your Video Doorbell Pro dying. A restart is unlikely to help with this situation as power is the main concern here. If you have already had a replacement and this one died as well, it likely has something to do with the transformer or how the Doorbell is connected to it. Check out this Ring Help Center article, it will help explain this in more detail.


Hello Riley_Ring, I checked the transformer’s connection to the power kit. It appears to be properly wired. I’ve repeated this procedure several times over the past couple weeks and must assume the wires from the kit can attach to either the Trans or Front screws. In fact I’ve tried all combinations of hookups including using the simpler wires from the newer kit. Same results; no change to doorbell power (or lack of it). The other option, the AC adapter, is not a player here. I’m not drilling holes in the wall just to get your doorbell to work as advertised. Needless to say I bummed. Thanks for trying.

Hi @philG , do you know the gauge of the wire that is connected to your Pro? Also, how long is the wire from your transformer to the Doorbell, is there any excess?

Also, I moved the post and updated the title from the comments of the original article it was in to make it easier for other neighbors to find if they are having the same concern.

1 Like

You’ve exceeded my capabilities, so I’m calling in a pro.

Hi, if a replacement died as well, it definately sounds like a power issue. Either the transformer is failing or it’s is not rated high enough for the Ring PRO., or there is a issue with the wiring possibly associated with your bell unit.

Is the PRO setup and connecting at all. I.e. does it set up and then die once you press the bell button? or does it seem completely dead?

1 Like

I had the exact same problem. On my second ring pro. Even have a new transformer with 40w rating as recommended by ring and Amazon support. Worked fine for a few hours and died overnight. When they were working both power and network signal were shown as good in the app. All other devices work fine and the router is on a UPS. Ring build quality is suspect.

Thanks for sharing these details @Nyarp . There are many variables that can cause power fluctuation, it sounds like you have a sufficient transformer so at least thats checked off. You will want to also check the gauge (thickness) of your wiring and how long the wire run is. Please ensure there is no old, corroded, or fraying wires in circuit as this can cause resistance, and a loss of power. We recommend contacting support for hardwiring concerns as it usually requires a closer look.

I have the exact same issue New transformer I see 26 volts all the way to the bell it worked for a few hours now nothing. Transformer is 24v 40vs there is a mechanical chime. Very frustrating.

I ended up installing a resistor in series with a new one (warranty replacement) and the new one now has been working fine for weeks. I can’t recall the resistor but something like 10 ohms 20 watt rated?

Hey @Claytron1116! This is definitely not how the Video Doorbell Pro should be operating. We recommend reaching out to our support team for more isolated troubleshooting, at 800-656-1918, if the suggestions in this thread did not lead to a solution for you. Thank you!

They are sending me a replacement unit

On line research indicates we now, after 9 months of an excellent experience, have a power problem? Door bell device is dead. Now we need a Ring power cable? Makes no sense.

I have the similar issue. I bought the whole set with power transformer kit and it wasn’t worked after installaiton. After the replacement, it’s worked properly and excellent for around 3 months. However, it suddenly went offline last week. I’m trying to reconnect it with my WiFi but the device seem no respond and no light, no spinning, even I pressed and released the small button on side. The device seem is dead. The last reported voltage is “Good” and the reported signal strength is “RSSI-63”. What should I do? Replace it with a new one again?

Similar issue here… Ring Pro was installed in Aug-2017 and has been a champ… Good voltage readings, including the last one just last night at midnight. RSSI= -36 (still don’t know if being closer to 0 is good/bad).

No lights at all around the button and pressing the reset button has no effect…

Appears dead…

That is a high RSSI, @MaxChico - Did you check the current power of your transformer? Have you contacted support?

Im having the same problem this is the second unit .They sent me a new one after the first one kept going offline. Now with this unit i cant reconnect to my wifi I tried to hard reset it and at first it would blink blue then the light would go off.Now i get nothing its dead.If they don’t replace this unit again Im just gonna another brand. I also have a floodlight cam they replaced because it crapped out just after the warranty expired ,they did replace it but my point is thier products suck and are faulty.

I have the same issue with mine as well. Installed in 2017. Last signal shows RSSI-62. Last voltage report good. Will not respond to anything. I see these other posts are all dated this week. Coincidence???

Same with mine, been working fine for a year or more, died on 11/19/19. I wonder if there was an update or something?

This has to be a Ring issue. Nothing changed at my house in terms of power or wifi. No way that this many Doorbell Pros all died from various locations across the country within the same 1-3 days. Ring needs to look into this and fix it for customers experiencing this outage.