Video Doorbell Pro - Disconnects from WiFi in seconds

Hey all - Ok, so I’ve got a Ring Video Doorbell Pro. Installed no problem, and has been running flawlessly for a month or so. However, as of last week, the device drops from WiFi within seconds of connecting. I’ve tried 3 different WiFi networks, forced 2.4, everything I can think of. The AP is maybe 10 feet from the doorbell. Transformer voltage is good (green), RSSI is 46-49 (green), and when I reconnect to WiFi, all networks have full signal strength. I have set things up so that the only thing between my AP and the doorbell is essentially the front door.

But as soon as I get the device connected, it drops within seconds. But prior to last week (and no, I didn’t change anything on the doorbell or my network infrastructure) it was staying online with no problems.

I also have a Spotlight Cam Plus, which is about 50 feet away from the AP, and it never drops connection. Same WiFi network, higher RSSI value (63), but it stays on all the time.

Any thoughts as to why my doorbell would drop like this?


Hi @FringeEvent. Those were good troubleshooting steps to try for your concern. I would also recommend rebooting your Pro by pressing and holding the setup button on it for 20–25 seconds. Since the Pro is a hardwired device, I would also recommend making sure that your wires going to the Pro are providing 16–24 volts. If you are not comfortable testing live wires, I recommend consulting a qualified electrician for help. If you have tried these steps and are still having this concern, give our support team a call for further assistance.

Thanks @Justin_Ring. So when I see the Transformer Voltage as ‘Good’ (in green text), does that not indicate that the device is receiving voltage between 16-24 volts? I’d really like to avoid having to purchase tools necessary to determine exact voltage, or have to pay an electrician if the device is already indicating that the voltage is adequate. Thanks!

Ok @Justin_Ring, new update. I went out to work through the reset process (again) and this time the indicator light was blue. Not spinning, but coming up from the bottom on both sites to meet up at the top, over and over. So I tried to reconnect the device, but was unable. So I proceeded with the reset procedure. I got the indicator light to the white circling motion, and worked through setup steps. However, the doorbell died about halfway through the process. Lights went out completely, and pressing the doorbell button caused no response. Is this a bad unit? Do I need to RMA/exchange?

Hi @FringeEvent. If your Doorbell Pro is unresponsive, it would be best to get in touch with our support team to explore further troubleshooting options. Once all applicable troubleshooting has been completed, our support team can help determine the best solution based on your device’s warranty.

Thank you, @Caitlyn_Ring. I will reach out to the support team. My device is only 2 months old.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.