Video Doorbell pro dead on installation


I recently installed a Doorbell Pro using a Ring Plug-In Adapter, but the doorbell is not powering up.

I do get 27 volts from the adapter, so power should not be an issue.

Looking in to and trying all the solutions given in this community, I made no progress whatsoever.

Google gave me a solution to connect USB to the doorbell (I guess the warranty is void now), and the doorbell instantly powered up and worked as intended.

Left it overnight connected to USB before I connected it to the adapter.

The doorbell is still dead installed the proper way.

Are there any solutions for this?

Hi @jkjern. Since you’ve tried to power the Pro up with the micro USB on the side and it is not powering on, it would be best to contact our support team. They’ll be able to take a closer look at your device and provide more advanced troubleshooting steps for this concern. Please give our support team a call at one of the numbers availablehere. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.