Video Doorbell Pro constantly showing Poor for Power

So, I installed a Ring Video Doorbell Pro about a week or so ago and the app constantly says the power is poor and 0mv. The doorbell has worked as it is supposed to but sound stutters at times and if the doorbell is pressed it sometimes looses connection with WiFi.

We currently have the Video Doorbell Pro at the front and a regular push button at the rear of the house with a set of chimes for front and rear. When I originally installed the Pro doorbell along with the Pro Power Kit, the transformer that was in the basement was rated at 16v 10va. Rear doorbell chime workes fine throughtout all my testing and changing of things but Pro doorbell has yet to say it is getting anything but poor power.

After a couple of days of the app still showing Poor for Power, I replaced the 16v 10va transformer with a 24v 40va transformer. Still had the same Poor for Power issue. So, I just recently replaced what looked to be 24 gauge wiring running to the doorbells, transformer and chimes with 18 gauge wiring. Still have the Poor for Power issue.

Not sure what is left to try other than cutting out the chimes and getting the Pro Power Cable and connecting the doorbell directly to the transformer to see if that solves the power issue.

I am sure everything is wired correctly and have tried removing and reinstalling the Pro Power Kit multiple times but still have the power issue.

Anyone have any other suggestions to try other than cutting out the original chimes and wiring direct to the transformer to see if that cures the power issue.

What I thought was going to be a piece of cake to install has turned into a real pain in the butt to get working correctly.

And lastly, does anyone know what the largest wifi key that can be used when connecting to my wifi network? I use 63 character keys for my wifi SSIDs and I couldn’t get the Ring Doorbell to connect to either my 2.4 or 5ghz SSID unless I reduced the key length.

Thanks to any and all that can shed some light on what might be going on and how I can get the doorbell to say it is getting enough power.

Dan

Hey @CBR954RR. After reviewing all you have done and the concerns that you are running into, I highly recommend to reach out to our support team over the phone. They will be able to see why the setup is failing with your wifi SSID concern, as well as to why the Doorbell’s power supply is showing at 0. Please reach out to our support team here over the phone to get this address and one of our advanced technical support agents to look into this further for you. :slight_smile: