Video doorbell pro blue light blinking upward

My RVD was working fine for a few monthes now.

I tried to connect it to a new chimes pro to improve wifi reception.

It has restarted, and now it always blink in blue in the half top led, with no possibility to switch to setup mode (orange right button does nothing).

Hard reset only restart it in this blue blinking mode.

Voltage is still the fine 24V which always worked.

For these tests my wifi router is 20cm from the doorbell.

What can be done to unlock this situation ?

Hey @Kood. Could you try resetting the Doorbell by pressing and holding the set up button for 30 seconds? After this time has passed, give the Doorbell a few moments to boot back up. From there, disconnect the power to the Doorbell Pro, and then after a few minutes, restore power. At that point, give it a minute or two to boot back up, and then press the orange button to get it into setup mode. It should spin white when in setup mode!

Hi Chelsea,

Thank you for your quick response.

Unfortunately, the doorbell is still blinking blue for each restarting (hard reset for 30s and power-off for a few minutes after the restart).

The device never enter setup mode.

Ironically I had the same issue two days ago when I set up on my ring pro. Although my first set up was complete, at time of use, the app didnt sync with wifi password and kept rejecting it.

So when i tried hard reset (as the side button didnt do anything), powered off the mains and switched on. Now according to manual, I should see white light spinning, but it was the blue light that spinned and it got stuck 75% completion. After trying multiple things, I gave up and left it. I think 30 mins later, for some reason it did a “reset” and then started working. Not had problems since.

I wonder the main powered ones needs some time for a proper reset? Dunno…but my assistance here wil be leave it for 30 mins and see if something changes in that time. It does say “rome wasnt built in a day…”

@Kood Thanks for giving it a try, and I’m sorry to hear it’s still just stuck in that blinking pattern. @todaymorning04 Makes a great suggestion, as sometimes, especially with the Ring Video Doorbell Pro, it does need to get some charge from the transformer after the first initial setup. Although, if this is still persisting today, please make sure to give our support team a call here!

1 Like

Thank you all for your response, unfortunately, the doorbell still refuse to start after a long period of charge (a week).

I will contact the support team, thanks again.

1 Like

Hello ring team and ring users,

I’m having the exact same problem at my end. Did @kood get any usefull feedback from the support team?

Any other suggestion on how to fix this?

I have the same problem and Ring Support sent me their pro kit. I installed it and resetted the doorbell a number of times. No luck. I am stuck with two doorbells pro. Live chat is off. I need to at least replace them with 2 Doorbell 3 plus. Any help on how to go about this is greatly appreciated