Video Doorbell 3 Plus frequently stops working until I pop out and put the same battery back in

Hello. I have a Video Doorbell 3 Plus in addition to many other external Ring Cameras around the perimeter of my house. Most of these other cameras are hardwired, but I do also have one that is using a battery with solar panel. I am frequently having issues with my doorbell about 2 or 3 times (at least) per month. The doorbell will be working just fine one moment and the next it will stop responding to motion or doorbell presses. All other ring cameras which are at least double the distance away are still working fine. To fix, I have to pull out the battery, wait a few seconds, and then reinsert it. Note that it is the same battery when I’m doing this. It will then go through a cycle and start working again. I know the battery still has plenty of charge. This latest time, I checked the battery, and it was still 97% charged. I do also have an A/C adaptor hardwired to it to help keep the battery charged. I have 2 different batteries and it is doing the same thing regardless of which one I’m using. I confirmed the firmware and phone app is up to date. I am at a loss as to why this is happening with the doorbell, but all other cameras (again, at least double the distance) work just fine and I don’t have any issues with them.

Any help, comments, suggestions?

Hi @stboerma. When you notice that the Doorbell isn’t responding to doorbell presses or motion events, are you able to access the Live View from the Ring app? What is the RSSI listed as on the Device Health page for this Doorbell? This could potentially be due to temporary wifi interference, but the RSSI will give us an indication of the wifi signal strength so we can use the process of elimination to determine the solution.

Sorry for my delayed response. The Ring app says the camera is offline. All of my other cameras are online and working as expected. The app says “RSSI-45” for the doorbell under Last Report Signal Strength.


did you manage to fix this ?

Hi neighbors. If your Doorbell is becoming unresponsive and not responding when the ring button is pressed and not detecting motion, try the following steps:

Also, if you are using a third-party adapter to trickle charge the battery, that could be what is causing the concern. The only type of adapter that should be used with our Doorbells is the Ring Plug-In Adapter. Remove the third party adapter to see if that stops your Doorbell from becoming unresponsive. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

I have not yet resolved the issue.

I will try to swap out the adaptor for an official Ring adaptor. However, let me reiterate that when the issue happens, all I need to do is remove the battery, wait a few seconds, and reinsert the same exact battery. it then starts working again. I also had this same exact issue before trying to use an adaptor, so I don’t think the adapter is the cause.


I have same device and same exact issue. Device goes off line. Even added a Wi-Fi extender and have it within 5 feet of doorbell. Never reconnects automatically. Must remove battery for a few seconds and reinsert. When I look at menu after doing that it shows battery strength at 90+%. We are getting frustrated with this device.

1 Like

Yes, it is very frustrating. Especially when all of the other Ring devices that I have don’t have this problem.

I too have started having the very same issue with my Ring Doorbell 3.

I’ve replaced the battery, changed the rings connection from my mesh WiFi to routers WiFi, disconnected the transformer and run battery only… Guess what, it still becomes unresponsive. Clearly there is a larger issue here, I can only presume a poor firmware update that has been pushed to the device by Ring which is causing instability?

Yeah, it could be bad firmware. Something is definitely wrong since all of my other Ring devices work just fine and don’t have this problem.

I am having this exact same issue with my Doorbell 3. It stops working, I pop out the battery, put it back in and it will work for maybe a hour or two. Incredibly frustrating - would love to know if there is going to be a fix for this problem soon.

Yes, very frustrating!

Same thing is happening with mine. Tried to reset. Changed batteries. Etc etc - nothing works. Still no resolution that has worked for you?

No resolution as of today. :frowning:

Hi, i have exactly the same. Thought it was the front door closing that’s causing it to lose network, but as others are having the issue, maybe not. Is it only the doorbell 3 plus that this is happening to. Can we get a replacement, as its not good security if the network wifi on the doorbell 3 plus keeps dropping.

Having to pull battery now as we speak

Hey neighbors. If the troubleshooting steps provided in the marked solution don’t work to resolve this concern, please give our support team a call at one of the numbers available here so they can further assist. If you are outside of the US, please visit here to see how to contact support.