Video Doorbell 2nd Gen CANT find wifi network - HELP

Hey guys!

I really wish I can get some help here, very frustrated with my Ring device.

Anyways I installed it in my new place, drilled the wall, everything working beautiful, paid the yearly fee for the service, 2 days later I noticed it wasnt working anymore and it was because it disconnected itself from the Wifi network.

Tried to reconnect it thorugh the App but my wifi network was not in the list, many other networks from the neighbourhood were but not mine. I checked the router, all perfect no issues at all. My Amazon devices , my phone, etc. all connected. Reboot it, changed the name of the 2.4 ghz network, hard reset the device several times, change the channel of the wifi several times, tried channel 1, 6, 11. Tried changing the password of the network., but it wont appear on the list.

It goes on setup mode no problem, connects to the app, and when I get to choose the Wifi network mine just wont appear. I dont know what else to try, I tried Google before posting this and I couldnt find any solution what worked for me. Battery was also charged to 100%.

It is very strange because it worked out of the box so well, I was actually very excited and happy about it lol, I really dont know what to do to fix it.

Anyone that could have an idea?

Again I already tried:

Changing the channel of the 2.4 ghz network, also name and password.
Hard reset the device to factory settings
Deleted it from my account
Deleted the App from my phone and reinstalled.
Tried a different phone.

Cheers

Hi @OscarCL. You’ve definitely ticked off most of the basic steps I would have suggested in order to troubleshoot this concern, so thanks for letting me know what you’ve done already. Since you have done the basic troubleshooting steps already and your wifi network still isn’t showing, I would recommend reaching out to our support team so they can take a deeper look and go into more advanced steps in order to find a solution. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have the same issues. Please share the solution?

Hi. How did you fix this problem? It is exacly the same problem as I have

Hi there, neighbors! When going through a setup in the Ring app, at the final step of connecting to your home wifi network, a list should appear of available networks to choose from. If this list does not contain your wifi SSID, please try tapping the “add a hidden network” option and entering your network information manually from there. Please also try this while in the same room as your wifi router. Feel free to let us know how this goes! :slight_smile: