Video Doorbell 2 - Solar Charger Status "Connected" But I Don't Have One

I’m having similar issue with my Doorbell 1 with solar sleeve. Battery drains fast since January. Solar statsus on App says “add a solar…”.

I contacted Support twice. What a painful experience. They put me through the script of resetting doorbell and having me go through set up again. No answer to why the “Solar status” in the app wasn’t saying I had solar connected. I asked them if they could tell the Solar was even working, they had me trigger an event and they said that it was working. I asked if there was a way I could tell and they said no, but they could tell from their end. Fully charged the battery and It’s been 2 days and battery is at 85%. It’s been sunny both days too and temperature in the 60’s.

Bingo! Ring knows this too, but they don’t know how to fix it. They already started selling the solar chargers so they cannot remove the feature from their app. Because our apps say the solar charger is connected, my suspicition is that software prevents the battery from taking a charge.

Add me to the list of people dealing with this same issue. ?
This is nonsense. How many customers have to be affected before they fix this issue?

2/21 update- (continuing from my 2/8 update): A third issue is identified, that is, when the battery is drained (says “very poor” in the display status), the “live view” does not work. Doorbell still works when someone presses the doorbell button. So I’m back swapping batteries after recharging the drained one. This is now very annoying, I had to do this every 2 weeks. I’m convinced RING DOES NOT CARE!!! to fix these issues. My 2 previous issues remain as issues (ie. “does not charge the battery” and "solar charger status “connected’”)

I have the same problem Ring 2 with Solar Charger. It doesn’t show connected and is not charging.


I’m getting the same thing everyone is describing. I emailed customer service, this is their response:

Thank you for responding to my email.

Can you please try to do the following:

  1. Reset the device by holding down the setup button for 20 seconds.
  2. After the reset completes, the device will need to be set up again.
  3. Then trigger or perform a motion.

Please do update me after this for me to check further here, I will be looking forward to your response.

Please do not hesitate on reaching us back once you still have future concerns. We will be happy to assist you 24.7

Is it safe to say people already tried this and still doesn’t solve the problem?

Thanks in advance!

They told me that the solar panel issue was an app issue and didn’t affect charging and was only iOS. That it was likely an issue with my device. I cal BS.

Yes, that’s the script they used for me too. And no, it didn’t help.

Just tried this procedure and the status is the same.
Does Ring look at these posts?

Now they’re blaming my ISP and wifi connection (which is BS)…

"Thank you for responding to my email.

Upon checking here on our system, I can see that the device is not getting enough connection which would cause the device to not work properly.

I highly do suggest to reach out to your internet service provider this will mostly be resolve and also would highly suggest to contact your internet service provider if in case the signal strength on your internet does not meet the signal needed on our Ring devices.

Wherein your internet service provider has an access to have some adjustments for the signal in order for the Ring device to get the signal needed for it to perform properly as how it supposed to be and also there could be some interference blocking on the ring device to your wifi such as mirrors, metals, glass, printers, wall bricks and other appliances specially the one’s where your internet is also used."

I have the exact same issue…

Same here.

iOS Version 5.23.0 released two days ago does nothing to fix this problem, which seems pretty common. I have a solar charger, but the app doesn’t show it. I can’t really tell if it’s doing anything, because my device has been at 90% for weeks (could be good, could be not so much), “Power Source” says “battery”, and the Solar Charger Status says “Add a Ring solar device…”


I don’t know what they’ve changed, but my doorbell is no longer dropping in charge. It isn’t charging up to 100% as it had in the past, but it was 45% a week ago and now it’s at 47%. Something is quirky, but at least it’s not draining and needing to be plugged in anymore for me. Funny how they denied issues, but seem to be working on them.

We are having the same issue as well. We have a Ring 2 that was working perfectly hardwired, but a week ago, I noticed our Live feeds were not working. Over the week, I noticed we weren’t receiving notifications anymore even when people are at the door. This lead to me noticing the battery is very low, so I charged it manually. I finally got the batter back in the bracket tonight, and now I see the solar charger is connected. I don’t see the battery charging anymore. What is going on?! Apparently, we aren’t the only ones having this problem!

They’re sending me a new doorbell, but not a new solar charger. I don’t think I need a new one for either. I actually think it’s a firmware issue, but who knows, I’m just a customer. :confounded:

Had same issue. The Solar Charger status connected shows up on our iPhone’s, but not on the android app. I think it’s related to the iOS app.

I have the exact same issue. Does anyone have an answer?

I have not yet received a reply…so frustrating. Luckily I have only had to disconnect and self-charge my Ring 1 twice since I purchased the solar charger. Defective charger??

I still have the same problem. The device has had updates and no change. No one from Ring seems interested in responding to us in regards to this obvious problem with their charger.