Video Doorbell 2 - Solar Charger Status "Connected" But I Don't Have One

The subject sums up my issue. I noticed when checking the device health of my video doorbell that it now has a section labeled “Solar Charger Status” that I hadn’t noticed before. It says “Connected” but I don’t own a solar charger and don’t have one connected to my doorbell.

This may not sound like a big issue but this discovery coincides with the discover that the battery has been completely depleted for at least 3 days even though my doorbell is hardwired. It had worked fine for over a year and half until this week. Now, I did set up linked events with my other cameras so it’s possible that the doorbell is working overtime and that could be the cause, but wouldn’t it at least have charged a little over the past 3 days via the hardwiring? Of course, another possiblity is that the battery is at the end of its life and needs to be replaced (I’ve currently got it charging on a micro USB cable so I’ll see soon enough).

_ But my main question is is it possible that since it thinks a solar charger is connected that it’s not using the hardwiring anymore and therefore not charging at all? _

Thanks!

6 Likes

I have the same exact issue. I’ve been swapping 2 batteries (1 original and one new battery backup) after fully charging via usb since 5 months ago. Hardwire voltage is per recommended rating but battery is draining after a week and not getting charged. I also noticed the solar charger status as connected, yet I don’t have one. My Doorbell 2 is a little over 1 YO.

3 Likes

Just chiming in to hopefully get an answer myself. Same exact issue. Back door hardwired shows no solar and is charging fine… front door hardwired and show solar connected is now drained of battery energy. This was all fine for 2 years until recently.

1 Like

Same issue, started last night. I’d say it sounds like a software update they pushed out. Been on with support for awhile which has been useless.

2 Likes

I have the exact same issue. I just got the solar charger connected update yesterday, and I don’t have a solar charger. It is draining but didn’t appear to recharge at all last night, for the first time (and it wasn’t that cold). Has anyone found a resolution?

2 Likes

Hi all,

I think I found my problem. I had linked my doorbell and my two floodlight cams together so they would all record when any one of them picked up motion. I live on a somewhat busy corner so there were already quite a few events triggering my cameras individually but linking them all must have just been too much for my doorbell. I unlinked the doorbell from the floodlights, charged up the battery manually, and since then the battery has remained 90-100% charged. It’s been several days now so it seems that was my issue. The doorbell wiring just couldn’t keep up with all of the new events the camera was handling.

I still wouldn’t mind knowing why it shows a solar charger is connected when I don’t have one. It’s still possible that is affecting the charge rate I suppose.

1 Like

Opposite issue. I have a solar panel but it doesn’t show as connected.

8 Likes

I installed a Ring Solar Charger on my Ring 1 over a week ago. It is in full sunlight. When I go to Device Health on the App, it shows my battery level slowly decreasing, and the Solar Charger Status says “add a Ring Solar Device to extend battery life”. I did that. How do I get the app to know that, and why don’t I see the battery at 100%? Thank you.

8 Likes

Same issue also here. No solar charger installed but app tells me that solar charger is active. And battery charge is decreasing even though my doorbell is wired. This combination has worked without any issue for last two years but suddenly problems started few days ago. Hopefully just sw/firmware issue.

2 Likes

I have the opposite problem - new Ring Doorbell 2 installed with solar charger last week. Device health says “Add a ring solar device to extend battery life.” The support guy on the phone was useless.

4 Likes

Same thing here and a few more as we see it. Just got off the phone with customer service. They were polite and are sending a new battery and bracket, but totally missed the point on the new solar panel connection. I don’t have a solar panel! I asked about the latest firmware date/push, but couldn’t get an answer. Many additional posts to this issue seem to be referring to same timeframe when the issue began. RING, if you’re there and listening…please look into this. A firmware fix seems to be in order and easiest! Thanks!

2 Likes

I have the same issue too. Battery had been re-charging well until 2 days ago and polar charger status also says connected. Very frustrating. I think it is a SW issue.

1 Like

Same problem as original posting. Solar Status - Connected. and Battery not charging, in essence depleting. Just got this Doorbell installed brand new two days ago. Spent an hour on tech support, after having described the issue multiple times. Had me do complete reset - that did not fix it. Then escalated to advance support, who only gets communicated to by 1st level through chat. They continuously believed it was just a bad ‘reporting’ issue with the app, but reinstalled the app and tried on a another at their request to prove that was not the problem. Ultimately, they have NOT resolved this and said they would escalate and get back to me. I’m uncertain of that happening. Given my experience today.

Has anyone found the answer to the solution. I based upon prior comments, I tend to believe that one of their fimware updates is the problem.

Update: I followed the service tech’s instructions to disconnect the doorbell from the charger and reconnect it. Still getting a message to "Add a Ring solar device to extend battery life, but THE BATTERY IS CHARGING! Sounds like it might be an app problem instead of a firmware problem?

2/8 update- I stopped swapping batteries (i.e. replace drained with full charge battery) to check what happens. Doorbell still works since it’s hardwired, but the “power status” still indicates battery is “very poor”. Also, it still indicates solar charger status as “connected” even though I have no solar charger connected, so these 2 issues remain.

Update. To rule out that I have a defective unit. I got a 2nd one. I instead of hardwire and configure I started just using battery power to configure. At the end of this, the solar status ‘connected’ went away. Then I connected the doorbell button leads for power and within 3 minutes. It showed solar status as connected. And no increase in the battery capacity. IOW not charging.

Having same issue. Have Ring 2 and no solar charger but shows a charger is connected. Not seeming to have battery issues but still it’s not fixed on 2-14-20.
I did have several hours last night where the feed from my doorbell was “not available” and today it had a hard time showing me the live image. Guessing a software push went out last night. I went out and triggered a motion alert and now the live image works. But we shouldn’t have to trigger it to work! What if I wasn’t home? My view is dead and the entire point of the doorbell is lost if it doesn’t work reliably.
C’mon Ring, get your customer service folks up to date!
I don’t think they do a good job of updating their customer service reps with the latest software push information.

1 Like

Okay, put me in the group with the battery dying quickly while hardwired and showing solar charger status connected. Mine got wet today pressure washing the walk and I thought I did something wrong. How can this issue go on without any resolution? My battery will be lucky to last a day per charge the way it’s draining.

1 Like

I spent almost 3 hours with tech support over 3 days. They simply failed to understand. I used to be in IT so I diligently explained the problem over and over. My own solution was to disconnect the hard wire connection for now and just recharge the battery manually. They treated me like an isolated case, although I told them that based on the Community site I was not. I figured that thousands of people would start to see the problem as their batteries depleted. Maybe with enough misery they will realize that I am not an isolated incident.

@ RLW ring messed up and they are so stupid that they can’t reverse the firmware update … I’ve written enough about this. 3 years it worked perfect. End of December , firmware messed up everything. Not I have to charge every 4-5 days

1 Like