Video Doorbell 2 not able to activate Live View connection using Netgear Orbi mesh wifi network

I recently installed a Netgear Orbi mesh wifi network in my home to replace a 4 year old wifi router with extenders. The mesh network automatically chooses the best connection of 2.4 or 5 Ghz for each wifi device including our Samsung Galaxy smartphones. Because of this the phones are connected at 5 Ghz but the Ring Doorbell 2 is using 2.4 Ghz. This is obvious causing a mismatch with wifi connectivity between the Ring app running of the phones and the doorbell itself. There does not appear to be anyway to force the Samsung phones to switch to the 2.4 Ghz band when trying to activate Live View. The Netgear Orbi offers no option to choose between 2.4 and 5 Ghz bands per device. By the way, I do suspect that this problem may turn out to be a general mesh network issue regardless of the wifi network router vendor chosen.

I hope that Ring will quickly address this connectivity issue and publish a fix.

Are you certain it’s due to the wifi? You can just try the same on cellular data and see if it works.

I have a similar problem with my Samsung Galaxy S10 phone and I started seeing this problem as well starting last week after the update to Android 10.

However, the trigger for me is a bluetooth device connected (my samsung smartwatch) that is capable of making calls. If I turn off that device live view works fine. There’s clearly a bug in the ring app that is attempting to “spin” trying to make a call (?) and fails somewhere related to the device (my smartwatch). This was evidenced in the event logs when the app freezes and provides an option to submit a bug report.

Also Rapid Ring works fine as well.

Hopefully someone from the ring dev team looks at this and they fix the bug which renders ring useless.

Thanks a lot for the information. I had exactly the same problem with my S10+ right after Android 10. I ended up to 3 times factory reset. As soon as I saw your comment, I disabled the Bluetooth and disconnected my Active Watch 2 from the phone. Problem solved. I hope Ring fix it ASAP. It’s so annoying ?

I can confirm the live view works on my Galaxy 10 ONLY when the blutooth is off entirely or I shutdown connection for my Galaxy Watch.

Thanks for your replies. I believe my situation as first reported does not involve a smart watch using BlueTooth. I have a Galaxy S9 phone and my wife has an S7. We disabled BlueTooth and the problem of not being able to activate a Ring Doorbell 2 Live Connection remains.

My network isn’t on mesh. I have a netgear Knight router which broadcasts both 2.4 and 5. My phones are on 5 and Ring on 2.4. I have some suggestions for you:

  • take the battery out of Ring and put it back in after couple of minutes.
  • reset the network in your phone. Go to settings and search for reset network. It will delete all your wifi and bluetooth settings. Then you have to reconnect them again.
  • if none of them works, then painful factory reset on your Ring. Don’t worry about your your subscription. It will stays.
    Sorry for ruining your topic by talking about our bluetooth and smart watch issues. ?


Sorry for hijacking the thread.

Did you try disabling wifi on the phone and see if live view works for you?

Although the ring devices work at 2.4Ghz and phone may work at 2.4 or 5 Ghz, that should not be a concern, since Orbi must be able to bridge between the two networks properly or the whole network would be broken.

I have a Google wifi and it works the same way and I have no issue with the wifi network itself for live view as well as for the other gazillion other smart devices that I have.

Thanks for your suggestion, however, if I disable wifi on the phone haven’t I just isolated the wifi network and the doorbell from being accessible to the Ring app on the phone. There is no connectivity.

Not really. Your ring connects to the ring network via the internet (through the wifi network). And so does your phone. Your phone should be able to access the doorbell from anywhere.

Maybe I misunderstood your question.

Is the ring doorbell connected to the wifi network at all?

Hi. You are corrected. With my phones wifi shutdown, the Ring app does connect through the cellular network with my doorbell, however, the problem stays identical to connecting via my phone’s wifi. In both cases, the Ring app tries to activate the camera but eventually times out. When I click retry sometimes it can connect and sometimes not.

Extra info: I tried the suggestion posted by the other community member to basically reset my phones networks and bluetooth. Did it hoping this would solve the Live View problem. Same result. I then tried a factory reset with the doorbell as well as reinstalling the Ring app and clearing data. I reinstalled the doorbell through the app. Initially, things appeared to work and then it reverted to the same problem I began with.

Hi. I tried the suggestion you posted to reset my phones networks and bluetooth, the doorbell, etc. I even wiped out and reinstalled the Ring app including clearing data. Same result. I reinstalled the doorbell through the app. Initially, things appeared to work and then it reverted to the same problem I began with.

Sure looks like there is a Ring app issue with Netgear Orbi.

Try this one as well:
Put your call in airplane mode. Then manually activate the wifi only.
I hope in this way you can confirm the issue is with your wifi only,and nothing else.

I followed your suggestion re going into airplane mode. No net change to my ability to access Live View.

I promise. This is the last suggestion ?
Go to your router’s setting and find Access Point. Then disable it.
If this doesn’t work, then forsure, return your router ?

All suggestions are welcome. The Netgear Orbi’s access point setting has been turned off since its installation.

I remember one time I installed tplink extenders and they ruined my Ring connection. Ring isn’t a user friendly piece, but their customer service has been helpful to me, anytime I called them.
Unfortunately, I don’t know anything more. ?

Just found this thread. I to was having issues with live view not working with Galaxy s10 sure enough turned off my Gear watch BT and live view instantly started working again then I turned the watch back on and live view just gives about a half of a blue circle and locks up.

Hi Skew,

I wish my Live View access problem turned out to be a smart watch problem. Glad you solved your access problem. My problem appears to be an intermittent incompatibility between the Ring app and my new Netgear Orbi mesh wifi network. Sometimes I can get to Live View within a second or two and other times it won’t connect at all.

Thanks for everyones’ suggestions. I finally got Live View to work reliably. Maybe this solution will help others. The Netgear Orbi satellites each have an ethernet port. I took an old wifi signal extender and plugged it into the satellite closest to the Ring Doorbell via an ethernet cable. I configured the extender for just the 2.4 Ghz band and gave its own wifi network a name of <my Orbi network’s name>_Ext. I then changed the doorbell’s wifi connection to <my Orbi network’s name>_Ext. The doorbell came right up and has been accessible with Live View since the change. It has been 5 days.

On a separate note, I was using Live View remotely while sitting in my car via a cellular connection . As soon as I click on Live Vew in the app, my Samsung Galaxy S9 tried to make a bluetooth phone call to my cell phone number via my car’s entertainment system. There is most definitely an erroneous bluetooth event occuring with the Ring Doorbell app. This confirms some of the other posts about bluetooth issues.

If your phone is connected to the car it will connect as a phone call for 2 way audio. This is the way that works.