Video doorbell 2 no longer shows hardwired and no longer charges

I have a ring video doorbell 2. When I initially installed it, I hardwired it to the existing wiring. Everything worked fine for a couple years. Device reflected that it was hardwired. I never had to charge the battery and mechanical chime would chime when someone pressed the button.

Then, one day, it just stopped being listed as hardwired.

I suspected the transformer was blown, so I swapped that out with Ring’s brand transformer 16v 30va. Transformer worked fine. Putting out 18v at the transformer and 18v at the doorbell.

Then I thought it might be my mechanical chime. So I swapped that out for a chime noted on ring’s website that is compatible. Still getting 18v at transformer and at the doorbell, but still not charging.

Did the reset like every other article says to do. No go.

If I cross the wires at the doorbell, the circuit completes and the mechanical chime rings.

I’m at a loss. Am I missing anything? I’m told a diode or resistor is not needed for this doorbell as I have a mechanical chime on the circuit.

Am I missing anything else? I have a feeling my video doorbell is bad.

Hi @user50729. This Help Center article here has some information about Hardwiring your doorbell. What is the current battery level of your doorbell? Once the battery falls below 90%, you should see that the hardwiring is trickle charging your doorbell.

Thanks, @Tom_Ring . I already followed that link prior to reaching out here on the community.

I have ring video doorbell 2.
no digital chime - so no diode needed
link says no resistor needed for ring video doorbell 2.
link says no pro power kit (PPK) required for ring video doorbell 2.
Link says transformer voltage must match chime voltage. Transformer I have is Ring brand 16v 30va.
Link provides list of compatible chimes. I just installed Heath Zenith SL-2796-02. This is 16v chime which is on the compatibility list and is compatible with the voltage of the transformer I just installed as well.

Transformer and chime are both brand new, recently installed.

Battery level at the time everything was hooked up was 100% (freshly charged). It is now sitting at 86% and still listed as power source battery. It does not reflect hardwire. It did when I originally installed the ring doorbell about 3 or 4 years ago and it did trickle charge like you say. No longer, however.

Hi @user50729. Thank you for this information. With this in mind and considering the information you’ve provided, I think the doorbell may not be functioning as it should be. I suggest reaching out to our support team to look into this further. You can send us a private message on Facebook @Ring, or give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.