Video Doorbell 2 Losing Connection Frequently

I’ve had my ring Video Doorbell 2 Cam for over a year now and since it was installed it’s frequently losing connection with the wifi and will never re-establish, leaving it offline for the majority of it’s life. I feel the longest it’s ever been running non-stop is about a month, then I’ll need to open up, reset it and re-establish wifi all over again.

Here’s my current setup:

  1. Wifi AP is 1 metre away from the doorbell
  2. Doorbell has assigned static IP in DHCP, but have tried with a non-static as well
  3. No other conflicting networks - system is on a mesh, but have tried without the mesh as well
  4. Doorbell is hardwired and I have tried switching to two separate batteries
  5. Wifi is 1gigabit, with ample bandwidth for the device itself - we never hit our ingress/egress caps
  6. Wifi is Wifi6/5G - 2.4 to 5.2ghz
  7. We’ve tried with two different routers
  8. No other device in the house exhibits this behaviour
  9. Wifi is secured with WPA-2 Personal (AES)

I’m at my wits end - does anyone have any advice or how I can report a faulty device?

Hi @Sammich. Thanks for listing out all of the troubleshooting steps you’ve tried already. You’ve covered a lot of the basics I would have suggested, and even some more advanced troubleshooting steps. If you haven’t already, try creating a guest network on your router that provides only a 2.4GHz connection. Some neighbors have seen success with this in the past with similar concerns.

The Ring Community is a peer to peer forum where neighbors can ask each other for tips and tricks on different questions and concerns, but more advanced topics might require a deep dive from our support team. If the guest network doesn’t help with the connectivity problems you’re having, I’d recommend following up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.