Video doesn't load in Nearby Incidents

After an update some time ago, videos in the Nearby Incidents part of the app started having problems. I just updated the app again today and it’s still an issue. Scrolling through the list only some of the videos load. I’ve also noticed that some of the incidents display the wrong video, a duplicate from a different incident. Going into an incident to view comments etc. videos also won’t load most of the time. And something new with this latest update, if I let the app just sit for about a minute, presumably trying to load the video in the background, eventually the app crashes.

I’m on an iPhone X with iOS 13.4.1 and Ring app 5.27.1

Hi @thaueisen thanks for this post! I’m on an iPhone 8, app version 5.27.1 and checked out my recent ‘Nearby Incidents’. Although I do agree some videos take a bit longer to load than normal, they do eventually load. Have you recently tried uninstalling and reinstalling the Ring app? Also, is there a certain “type” of video that doesn’t load (Crime, Unexpected Activity) vs the others? Let me know if the unistall / reinstall works! Thank you :slight_smile:

1 Like

I have been having this issue ever since the last update, have already deleted and reinstalled app and still doesn’t work. Seems to me it worked fine until the overloaded too much junk update. This issue really needs to be fixed, doesn’t matter if it’s on iphone or ipad or mac, videos will not load. Seems a big number of people are having the same issue.

Hi @LindaRK. I would first make sure that the iOS on your iPhone/iPad is up to date. Once you’ve ensured that, close all other apps on your phone and then try launching the Ring App to see if there is any improvement. Try doing this on wifi and cellular data, and be sure that the Ring App has permission to use your location. If you are unsure of this, simply remove the Ring app from your phone, reboot your phone, then reinstall the Ring app. After that is complete, login and your device should be up to date and all permissions should be allowed! I hope this helps!

My IOS is ALWAYS up to date, No other apps are open and I am NOT going to try on WiFi & cellular because I rarely use cellular, and never on my Ipad. I have removed on both devices then reinstalled and also have reset the entire RING Pro and that does not work either. My devices are up to date and all permissions were allowed and no it does not work. It was working just fine until your update then it wiped out everything. Further, I don’t know what a Covid badge and an extra add your Amazon account info has to do with a doorbell. I don’t know if you work for Ring, but this is a crappy way to try and fix it. I should not have to jump through hoops to get it to work when it was just fine before. I know I sound like I’m really going off…ANGRY!! Thanks for trying anyway…

Hi @LindaRK. If you are still experiencing this issue, I would reach out to our support team to help you get to the bottom of this. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Thanks Man…I did try everything suggested and nothing works so guess I will do that…and thank you for your help…

1 Like