Unable to use Live view with Galaxy watch connected.

I think the concern is that the app seems to be a stop-gap to address some complaints and could easily become an app that is not supported or updated by ring which would mean back to Sq1.

Given the cost of these doorbells and for some, the annual running costs, the service from Ring is terrible.

I’ve had support calls with them and then forgotten about once they have decided the scripted responses no longer apply.

I was on the trigger to get a Nest over the weekend especially as I am “googled” at home but the one thing Ring has is compatibility with 8v doorbell chime boxes in the UK. Something Nest will never work with the current products and resolve it meant almost the same cost as the bell going to an Nest approved sparky.

any word on if RING is fixing this issue or made any progress?

This is a big turn off and I am thinking of leaving RING over this.

Still waiting myself…pretty frustrating. Saw a earlier posting that supposedly mid month there will be a fix.

Supposed to be fixed by 12/13 according to previous post. Mine still only works at night or with WiFi off. Bluetooth doesn’t effect it. Rapid ring is a crapshoot. Works sometimes. Doesn’t others. I’m with you. If it’s not fixed soon I’m replacing with something that works as advertised.

Well at least for me they did what they said they would do. Big thumbs up for the RIng team. Samsung pushed an update sometime last night to my phone. Had to restart this morning and Live view back up and running normally!

I received at the android system update this morning installed it restarted my phone turned on my watch and connected and I still can’t use live view

The new update has fixed my problems… live view now works for me from the Ring app.

I don’t have a watch connected so that seems to be a separate issue. Sorry to hear the update didn’t fix that. Just checked to make sure. Live view still working for me.

Just to clarify… I do have a watch (Gear S3 Frontier) paired. Live view with the Ring app did not work a few days ago and does now. It has worked all along with Rapid Ring.

I had an Android/Samsung phone update last week and just had a galaxy watch update tonight. The RING app still doesn’t work.

When I disconnect the watch and turn off the blue-tooth the RING app works. When the bluetooth is on, the RING app doesnt work.

The issue is more the bluetooth than the watch I think.

Another one here. Galaxy Note 10, Active2 watch. Latest software on all devices, and still can’t access live view unless I turn off bluetooth. App just locks up.

Another one here also… Samsung Note 10+, Galaxy Watch, latest Android updates, latest Galaxy Wearable software, latest Ring app but Live view just hangs when Bluetooth is ON. Useless and frustrating that this bug has not been resolved completely after nearly a month since being raised.

Yes Rapid Ring works as a workaround but I dont want 2 separate apps to manage my Ring products.

Needs to be fixed ASAP.

I just canceled my Ring service and am shopping for a replacement now. Ring used to be great product but has so many problems now it’s useless.

Same thing happens with my s10+ and galaxy watch thought this was going to be fixed on the 13th

Hello ring. Same issue here, I can only view video without my bluetooth and galaxy watch disconnected. This is not an option unless you want me to cancel my service. Product is worthless if I cant get quick access to live views when the doorbell rings. Fix your product, it not like I am the only person with a Note 10+ and a galaxy watch since this just happens to be Samsung’s FLAGSHIP PRODUCT!

I thought I was the only one, another note 10+ user having same issue… totally unacceptable. Hope we get a fix in next couple of days

Days? It’s been months and multiple Ring app updates and it still isn’t fixed. I had no choice but to cancel my subscription when support confirmed my issue and told me there is no ETA for a fix.

I was having the same problem and then I decided to enable the “NEW” timeline view and live view now works! I had not enabled the timeline view because I didn’t like it over the old interface. Obviously Ring has chosen to promote this interface over the old one and isn’t doing proper QA anymore. I haven’t seen anyone suggest this so give it a shot.

1 Like

I had been trying to figure out why so many were still having problems when it was fixed for me. That’s got to be it. I don’t even remember turning timeline on, but I like it.

Thanks for pointing that out!

Thank you! I had been using Rapid Ring as a temporary solution. I enabled the new timeline (I liked the old interface better too.) Problem solved.