Unable to login on Ring App

Hi,
Whenever I try to login to the Ring App on my Android phone I always get the message that an invalid email or password was used. It does not prompt for additional authentication.

I can login via a browser using the same email/password. I have managed to create a new user and login that way but it is not the owner so no access to chime.

I have cleared the cache in app, reinstalled the app and reset my password however it still informs me that an invalid email or password was used.

I do receive an email that my account was signed onto a new device.

Any suggestions welcome.

Regards, Jose

Instead of just deleting the cache, try deleting the app data too. If you uninstall, there will still be remnants of the app, deleting the data ensures a clean install.

Mark

Hi @SecretWombat. What is the OS version that you have installed on your Android and what specific model phone is it? What version of the Ring app is installed? Also, can you share a screenshot of the error that you are getting? I would also ensure that you do not have an active VPN on your phone, as this may be causing an error. Once I have this information, I’ll have a better idea of how to approach this concern.

1 Like

Hi,

I’m running Android Version 11 (RRFS31.Q1-59-76-6) on a Motorola Moto G50 and using v3.47.0 of the Ring app. The phone is not running any VPN and I have cleared cache/deleted app data and reinstalled the app with no luck.

The following screenshot is the only error I receive when I try to login.

I also receive an email with the following text
“Your Ring account was signed in to on a new device or browser. Here are the details:
• Device/App: Ring Community
• January 05, 2022 at 4:59 PM UTC †
• IP Address: 81.107.****
• Country: GB
†Coordinated Universal Time (UTC) may not
represent the sign-in time zone.”

However there is no prompt for a ring verification code.

If I create a new login then I can login to Ring and see my camera the only problem is that the account I have problems with is the owner so other accounts are limited in what they can do.

Regards, Jose

Hi @SecretWombat. Thanks for sharing that information. Here is something you can try. Login to Ring.com and navigate to your Dashboard and then to your Control Center. Once on there, go to your Authorized Client Devices. Now, remove all of your Client Devices. Client Devices are all of the devices that you have used to log into your Ring account with. Removing them may allow you to login to your phone. You can learn more about this here. Let me know if this works!

HI @Tom_Ring .

I removed all client devices and I still get the invalid email or password message on my phone. When I logged in to ring.com via a browser it prompted me for a ring verification code as expected which I do not see on my phone.

Regards, Jose

Hi @SecretWombat. Thanks for giving that a try. At this point, I think someone from our Level 2 Team of Neighbor Solutions Experts should take a look at this. They’ll be able to deep dive and find out why this is happening. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I have encountered the same problem.

Same is happening with me on iPhone running on ios 15.2. Whenever I try to log in to app it says invalid credentials and and not let me log in. Whereas with the same credentials I’m able to log in to browser. Tried uninstalling and reinstalling app many time but problem persists. Would really appreciate the support.

1 Like

I have a iPhone 13 with same issue and switching off my VPN cleared the login issue. Thanks Tom_Ring. The solution button tick box is missing so I could not accept this fix. Cheers

1 Like

Hi @Hideme. I’m glad that suggestion of turning off your VPN resolved this for you! :slight_smile:

Hi neighbors. If you receive any type of error message when logging in, please try the following troubleshooting steps:

  • Reset the password for your Ring account to ensure you are entering the correct password.
  • Make sure both the Ring app and your phone’s operating system are fully updated.
  • Attempt to log in on a different computer or mobile device to see if this concern is isolated to one device.
  • Disable any VPNs you have enabled as the Ring app does not support the use of VPNs.

If you’re still unable to get signed into your Ring account after reviewing the steps above, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. :slight_smile:

FYI, turning off the VPN did the trick. You can turn it back on and still get
notifications but having issues connecting to the app

1 Like

This is not cool that the app only works if I disconnect my VPN. I want secure access to my ring system more when I am out of my home than while i am home. While I am not at home VPN protection is more critical. What is Ring doing to resolve?

1 Like

Hi @user23636. This Help Center article here will have more information about the Ring app and using a VPN. I hope this is information helps!

That article about VPNs is mostly BS. Ring blocks many IPs/subnets from authentication. And it’s not just VPNs. They block many residential ISP IPs/subnets.

I have been through many of these threads, and I see the same canned responses that I can only guess/hope are made my those who just don’t know. I spent the longest time years ago with this same issue. I had to disconnect my phone from my home Wifi to be able to authenticate the app. Then reconnect. It is specifically the authentication steps for Ring that they have these added controls/restrictions enabled on, as no other aspect of Ring seems to mind that I’m on my home network (or VPN, etc.).

I’m again searching these threads hoping this has been resolved, as I have need to authenticate a home automation system that supports Ring. But it isn’t on a Wifi device (hard wired), so I can’t just switch it to use my cell phone’s hotspot. This restriction imposed on authentication is atrocious and not managing risk in a reasonable way. Most of these systems are setup for HOME use, yet many people can’t login to the app (or website) while on their home network.

It would be nice if someone who fields these support questions would actually escalate this issue. There are YEARS of complaints, and only canned replies suggesting “it’s your network” or “VPNs create technical issues”.

The issue is simple… Ring has something implemented that blocks various IPs/sunets (likely that someone deemed high risk; yes VPNs might pose that risk, but not generally residential ISPs). The solution is that they need to improve the quality of their deny-list. I’ve had the same IP address for my home network for over 2 years… I run a tight ship security wise (been my profession for nearly 20 yrs) and know there has been no malicious activity nor standard block lists that my specific IP has been listed on. My IP should not be blocked, and I’m guessing most of those having these issues from their home network should not be either.

I think I have solved the problem of invalid credentials on the ring app.
If you can login on ring.com but not the ring app try this first.
when you open the app clear the credentials if there are any present and do not use any predictive wording. I found that on my device the cursor was flashing one space away from the last letter, I pressed backspace once and the input boxes turned white and I was able to login. Let me know how you get on.

2 Likes

Thank you for sharing that helpful tip, @user27657! :slight_smile: