“Unable to join”

We have a doorbell, chime and 2 indoor cameras. They were all connected until about a month ago. Now we can’t get any of them to connect. We have tried to reconnect, we have removed them and tried to install them again. We get through the process and then get “unable to join”. The router is in the same location and hasn’t changed. We can’t figure out how to get these yo “join”

Hi @user75990. It sounds like something may have changed on your wifi network if this issue is affecting all of your Ring devices. I’d suggest reviewing the troubleshooting steps for setup failures here. There are some different steps you can try depending on if you have an iOS or Android device. Check that the ports and protocols used by Ring devices are open on your network. Lastly, you might also need to change your wifi channel.

If the solutions suggested above don’t work, please reach out to our support team at one of the numbers available here for more in-depth assistance. You can also get in touch with our support team on Facebook @Ring.