Unable to join Ring wifi for setup

Using the Ring app on my phone I’ve been able to get the doorbell to start charging but when the “Join Ring” wifi dialog box comes up I get an “Unable to join” message after pressing the join button. Any ideas on how to fix it?

1 Like

did you push the orange button on the back of the unit and then go to the wifi list in your phone and click on ring?

1 Like

I am also having the same problem! I have followed the detailed set-up and manual set-up, always end up pressing the orange button. In all cases, I get the “Unable to join Ring wifi for set-up” message. Also, there are no “Ring” networks available on my iPhone 10r set-up page.

Tom Gough

4 Likes

I also have the same issue. I can connect to the doorbell but the apps keep crashing everytime I try to get the doorbell to connect to our wifi.

1 Like

I was able to resolve the issue by fully charging the doorbell overnight.

1 Like

The solution for me was fully charging the doorbell before trying to connect.

1 Like

I solved it by first fully charging the doorbell.

1 Like

Unfortunately, my doorbell is a direct connect to the old doorbell wires.

3 Likes

so is mine

Hey neighbors! When the Ring setup AP is not allowing a connection, this can be indicative of mobile device connection or power concerns. If you are trying to setup a Doorbell Pro, please ensure your transformer is rated for 16 - 24 VAC and the wiring is not too thin or corroded.

I recommend also disabling any bluetooth, hotspot, or VPN connections on your mobile device, as well as closing apps in the background. If this concern persists, reach out to our support team, at 800-656-1918, for more in-depth troubleshooting.

Do you have to have the wires connected in the back before completing the wifi setup? When I try to go through the setup I get an “authentication error encountered” on my Andriod cell and a can’t connect message ont he wifes iphone. I have tried 3 different phones and even returned the ring for another and have the same issue, I see the Ring-xxxxxx wifi but cannot connect.

My Doorbell was working fine, I changed our home Wifi password and reset the doorbell on the 19th, worked fine for one day. Now nothing! It is hard wired, no battery issues. When I pull it off the wall and try to push the orange button, nothing! is the device dead? Do i need to open the body of the device and check the battery?

1 Like

Hi, i’m having this issue and no light is appearing on the front of the doorbell. Holding down orange button does not assist and ring is not appearing on wifi list on my phone

1 Like

I encountered the same issue – my ring cannot join wifi (or my iphone cannot join Ring’s wifi). Setup procedure cannot preceed further.

I tried all the possible solutions on the user manual, 1) click the side button(orange one), but no reaction; 2) restart my iphone, and click the side button for 15+ seconds to reset the ring device; 3) uninstall the Ring App and reinstall.

Unfortunately, none of above works for me. Very frustrating experience.

Can anyone kindly let me know Ring’s service number? I am sure the device itself went out.

Thanks

1 Like

I’m still having the same issues, hardwired and all, doorbell is working when I click it but now the ring app can not connect to the ring WiFi. Any suggestions?

I’m having the same issue. Worked for one day and now it won’t reconnect. Doorbell works and Ring has power. WiFi is working but always unable to join Ring network :confused: probably going to return the device. Hopefully I can get my $30 back for the subscription

Hi neighbors! If your Ring device is failing setup at the “connect to the Ring setup network” step, this can be related to power or mobile device. For battery powered Doorbells, please ensure the battery is fully charged. For a Doorbell Pro, sufficient hardwired power is obtained via a 16 to 24 VAC power supply. For first time setups of a Doorbell Pro, please allow it to power up for 30 minutes before attempting setup. The Doorbell Pro audibly announcing “setup mode” will be a sign of good power.

If the above power variables check out, the next best step is to check the mobile device. Try removing and reinstalling the Ring app on your mobile device. Feel free to try on another mobile device entirely if possible. If this concern persists, and the setup is still failing at this step, please reset your Video Doorbell by holding the setup button for 20 seconds. I hope this helps! :slight_smile:

3 Likes

Just had this issue…repeated cycling through the “unable to join ring network”. Tried multiple devices, turning off Bluetooth, etc. None of these worked. Finally tried rebooting device by holding side button for 20 seconds. After that it went right through and connected without any glitches. Thanks for solution!

2 Likes

I have exactly the same issue. Mine is a Doorbell Pro. Transformer is fine (full 24V). I set it all up and worked fine for a day. They moved it to install. I have two AP’s in the house one on Channel 1 and the other on Channel 11 both transmitting the same SSID. (I’ve read that Ring will not work on 12,13). The only difference is that it was connecting to the other AP. It would not connect and now won’t connect back to the AP on channel 1.

I have reset and can’t get back to the Ring-XXXXX network to set it all back up again. The unit is simply not transmitting it setup wifi network.

Have I bricked it !!!

Hi @gkelegha. If the reset as suggested by Marley was not successful in resolving this concern, please give our support team a call at one of the numbers available here. They’ll be able to take a closer look at your device and account to offer more advanced troubleshooting support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

1 Like