Unable to get past wifi setup

So I get to the point of connecting to my network, I enter the correct password and it sits there connecting, I’ve looked a tons of other posts, but nothing seems to work. My network shows the doorbell is in fact connected, but the doorbell flashes a white light to the left. I’ve tried on my ios phone and my android phone and still the same results. I don’t know if this is a common problem with xfinity or what, but it’s getting old. Any ideas?

I get exactly the same outcome. I changed from one wifi network to another and haven’t been able to reconnect my doorbell. I know it’s not my wifi as my ring camera connects, as do all my other devices including Alexa.

I deleted my app and all the other trouble shooting tips.

Hi neighbors! Since you’ve both ran through the basic troubleshooting steps and you’re unable to get your Doorbell connected to wifi, it may be best to reach out to our support team so they can take a closer look and provide more in-depth troubleshooting assistance. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: