Unable to enter xfinity wifi password for indoor camera

During the installation of my ring camera, when I try to connect to my xfinity wifi I am never prompt with a way to enter the password for my internet. But, when I connect to my mobile hotspot I am prompt with entering my password. Any clue why? First time dealing with xfinity I am not very familiar with it.

Watching, same here.

Sorry to see you both experiencing this! Try starting a new setup, going through all the steps as normal, and at the last “connect your device to wifi” step, choose “hidden network” at the bottom. This option will allow you to manually enter your wifi SSID and password. Let me know if this works for you!