Unable to connect to RingRin

Hardwired Ring Video Doorbell Pro

Worked perfectly for about 3 months, then always “offline.” Too busy with work (I travel) to try to fix until now. Bought a WiFi Range Extender thinking that would be the problem, but using the Ring app and following Ring directions to “reconnect to wifi” in order to connect to range expander Ring App says it will create a temp network called “Ring” and I should connect to it on my iPhone. However it won’t connect after many repeated attempts standing right in front of the doorbell which does have the swirling white light after pushing the orange reset button. Tried toggling wifi on my iPhone a couple of times. Consistently returns the error msg “Unable to connect to RingRin” after trying for a few seconds and now I’m at a dead end. Seems like I’ve pinned this problem directly on the Ring video doorbell but where to go from here?

Update: I have done the 20-second reset to try set up from scratch. Same issue…app tries to connect 3 times, then tells me to manually select the Ring network from my list of wifi networks, which I do, but it always returns the same error: “Unable to connect to RingRin.” This is standing just 2 feet away with my iPhone.

Also tried:

  • Powered down iPhone all the way and restarted. Same results.
  • Tried turning off cellular: Same restyle
  • Tried setting join networks to “ask” same results.

I am going in circles in the online troubleshooting and need better help.

Hi @DSMinFla. You’ve run through most of the basic troubleshooting steps I would have provided, which are outlined in this article from our Help Center. If you have access to another smartphone or tablet, I’d recommend trying the setup process on that device. Otherwise, the next step would be to follow up with our support team so they can look into this further. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Thank you Caitlyn, I just saw your post after working on this again for several hours. I started by completely disconnecting Ring from the power source for several minutes to be sure I’m getting a clean start. Seems like attaching to the Ring network just won’t hold. Best I can do (rarely) is get my iPhone to attach to the Ring network for just a few secs, then drops Ring and reverts to my newly installed Linksys range extender. A couple of times is proceeded to complete the installation, but failed at 31% twice, and once all the way to 95% before failing. Mostly…90% of attempts my iPhone just won’t connect to Ring (cell service off, ask turned on) all bars on my home wifi and just 3 feet away from the range extender. I’m using an iPhone 11. I will try again using my wife’s iPhone 13 pro. Appreciate the suggestion to try another phone. I’ll let you know how it goes as soon as I can get back to it. Dave M.

Well, this didn’t work either. Exactly the same results. I have full bars on both my and my wife’s phones looking at my range extender, same with the Ring doorbell, yet I cannot join the Ring network with either phone. I’ve tried different distances (within a foot, and up to 3 feet away), and different angles (phone to Ring, left, center, right, above, below), different orientations of holding the phone (vertical, horizontal, tipped, front facing, rear facing). Cell service turned off on both phones. Range extender is in “ideal” location per Linksys app and that is just 2 feet away from the Ring door bell on the other side of an exterior wall. I have glass the front door and a large window within two feet of the Ring doorbell. Having been an FCC licensed engineer in the past, I can assure you there is no signal problem here. Problem is with the Ring device itself. But now I am stuck with a $189.00 wall ornament that’s now deactivated unit because I had to relinquish ownership in order to try to set up with my wife’s phone which doesn’t work. I’ve spent untold hours trying to fix this. There is nothing left for this mere mortal to try. What now?

Hi @DSMinFla. I’m happy to chime in. As mentioned by Caitlyn, the next best step would be to contact our support team for further assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.