Unable to connect to Ring Network

My stick-up cam has been working brilliantly for months. Last week, our street had some issues with the fibre network, which meant I had to reset my router. Since then, I have been unable to connect the camera.

When I tried to simply update the wifi, I couldn’t connect to the Ring Network during set up - I tried on my own iphone, my ipad and my partner’s iphone. None would connect to the Ring Network - although it was showing up as an available network.

I have uninstalled and reinstalled the app on my phone and I have deleted the camera to try to install again, but the same issue - can’t connect to the Ring Network - so I can’t get beyond that point in installing. We’ve had a lot of crime on our street during lockdown, so I really would like to get this sorted ASAP! Hope someone can help. Thanks!

I assume that your base station is connected to the your home wifi and you now cannot connect your cameras to the base station? Did you press the button at the bottom of the cameras? I noticed the blue light only flash the very first time you try to connect the cameras to the base station (ring network). After that, if you try to reconnect again later for any reason, the cameras show no light until you press that button.

We don’t have a base station. Just one camera. It’s been connected fine for months. The problem is that when trying to set up, the app won’t connect to the Ring network. I can see that the network is there, but whatever device I use, I just get an error message.

Hi @kerenaf! When the setup fails while connecting the mobile device and app to the Ring device’s Ring setup network, it is best to check mobile device connection variables. Testing on multiple devices was a great step to take!

I recommend also ensure those mobile devices do not have VPN or Bluetooth enabled, and that they have the most up to date version of the Ring app. The next best step will be to perform a reset on your Ring device by holding the setup button for 20 seconds. I hope this helps! :slight_smile:

1 Like

Thanks @Marley_Ring - I did both of those things, so not sure which it was that did the trick, but everything is now up and running again! Thanks for your help! :robothappy:

1 Like