Unable to connect to BT Home Hub

My Video Doorbell 3 cannot connect to my BT Home Hub. I’ve tried numerous times, rebooted the router, moved the devices so they are literally next to one another.

This is the second unit I’ve tried so clearly there is an issue with the hardware itself - I’ve not had any other issues with devices unable to connect to the WiFi, including numerous laptops, tablets and smartphones. I can only assume the WiFi capability of the doorbell is simply not fit for purpose. Obviously many people do not have a problem - but the BT Home Hub is hardly some obscure piece of equipment so I am amazed Ring are allowed to sell this in the UK. The fact that there is no customer support apart from this community just adds insult to injury.

Ring Support for the UK is contactable on +44 1727 263045

I have a Ring Pro connected to a BT Home Hub so you shouldn’t have any problems on that side.

I am having the same issue, did you get a resolution for this issue?

I had the exact same problem these past few days and after much investgation I read the following article and it worked an absolute treat for me:

https://www.reddit.com/r/techsupport/comments/5e03q5/ring_doorbell_bt_homehub_setup_help/

My BT Hub was set-up with dual 2GHz/5GHz bands and when I changed these to be seperate, switched the 5GHz band off (as I don’t use that for any devices), this connected to the standard 2GHz band first time and continued through the set-up past where it used to stop (i.e. Flashing on the right hand side)

Hope that works for you.

1 Like

I have a Ring Door View Cam which will (as far as I know) always send motion alerts but is not sending alerts when the door bell is actually rung. I will get motion alerts when someone walks up to my door but it does not ring if they press the button. I have alerts on my phone and on my Alexa’s but have missed a number of people as I don’t hear the external ring on the cam itself (as outside) and it doesn’t “ring” on my phone or Alexa. I know there can be a delay at times but I always get the motion alerts even if a little late at times but the ring never then shows up on the timeline. It’s like it doesn’t log them at all. How can I get motion alerts but not ring alerts? I can even view the video of them walking up to my door and ringing the bell but this is under motion alert and doesn’t come up as a missed ring.

I live in the UK and have a BT router Hub 6. If I reset the doorbell by pulling out the battery and then reinserting it’ll ring a couple of times before stopping again.

I’m having this exact same problem with my 3 plus, it just won’t connect to my Homehub. I also have a Chime but that connected no problem and works fine.

I managed to connect the Rdoorbell to a range entender homeplug but that’s flakey and it keeps losing connection to that as well.

I’ve tried disabling 5GHz but that didn’t make any difference, it wouldn’t connect when I went into setup mode (two right side white lights).

I’m wondering whether I’ve just got a bad one.