Unable to connect Ring doorbell Pro to wifi

I’ve gone through countless steps during installation and I can’t get the doorbell pro to connect. When prompted to join it just comes up “unable to join”. I can’t even see the ring network on my wifi list. Please help


Hey @DannyV. Could you try the setup from another phone or device that can have the Ring app to see if this helps? In addition, you can reset the device by pressing and holding the setup button for 20 seconds and trying another setup. Let me know how this goes! :slight_smile:

Hey! We are having the same issue too! Did you ever figure out how to solve the problem? Thanks!

I am also having same problem, contacted ring. Tried everything including restarting modem, turning off per to unit and resetting doorbell. cannot connect unable to join do not see ring in WiFi selection. Doorbell has worked fine up until about 1 1/2 weeks ago

So frustrating! What happened when you contacted Ring? I have been on hold for over 30 mins trying to reach someone at Ring :frowning:

I was having the same issue and to be honest I didn’t find a solution, but apparently got told off by community managers for venting out frustration that when I click contact support I am taken to community help…I gave up trying for 1 day and left the device and miraculously the next day it was working great. Honestly I ain’t joking

Any luck on this…same problem - unable to join Ring 256803

I was having the same problem when using the Ring app on my iPad which is IOS 13. I swapped to my iPhone 6 which is IOS 12 and was able to connect to the video doorbell and reconnect it to wifi.