Unable to Charge Doorbell

Hi,

While I am using the correct USB cord (tried a few- which while tested on other devices works fine) the door bell does not charge when I connect it (using the Orange USB that came with unit.

I set it up to charge at 8:30 this am (no light showed that it was charging) and when I got back at 11am…there was no charge, no light showing that it was charging.

Tried other cords etc but had the same result.

Any ideas?

Thanks

HarrisS

Hey @HarrisS. Thank you so much for detailing your experience and explaining it for us here on what you have done. Since you have done the applicable troubleshooting, please ensure you charge up the device for at least 8 hours before use. If you have ensured it was charged for this time and it still will not set up or hold the charge, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.