Unable to advance or rewind history video on web

I have noticed recently that I am unable to click on the time bar to forward or rewind a history video on the website. When clicking on the time bar at the bottom of the video the progress jumps to where I click and then goes back to the previous time in the video. This happens when trying to click forward or backwards. I am unable to fast forward or rewind videos on the web site. I have tried in all browsers (Brave, Chrome, Edge) and the problem exists in all browsers.

Same here. Happens across different computers and browsers. Can’t click the timeline in the web player to advance or go back–it just returns to the point it was currently playing. Started maybe 2 days ago.


Hi neighbors. Thanks for bringing this to our attention. I’ve notified my team and rest assured, they are looking into it. In the meantime, if you need to scrub through your video, try pausing the video, then scrubbing. Thank you for your patience while we work to resolve this.

Same Issue as previous commenters

I just tried the web view this morning and noticed it was working as normal. I was able to click on the progress bar to advance or rewind the video.

Thank you Ring for fixing it.