Unable to add shared user in iOS app

I’m trying to add a shared user but when I enter a valid email, the submit button stays grayed. The select devices text also doesn’t do anything in touch. I tried this on iPhone 11 and iPad.

Hi @Expeditionaryman. Could you try adding this person as a shared user through the Ring website? Log into Ring.com and hover over your name at the top right. From that menu, select settings and then Users. Tap the plus sign at the top right and follow those steps to add your shared user. Let me know if this works!

Thanks for your reply. I was thinking along the same lines, but I don’t see any way to do this via the website. When I hover my name at top right, I get a menu (see attached screenshot), but Settings is not on that list. Also, digging into the ones that are there (e.g., Account), does not provide any Users options. Am I missing something obvious?

Thanks, ’


@Expeditionaryman This is pretty odd, as you should also have a section for Devices and then Setting right above where you have Activity History. I would recommend to log out of your account on the website, clear your cache and cookies, and make sure you re-log in with the proper email address connected to your Ring account. From there, see if you have Devices and Settings above where you had Activity History, and then follow my steps. If you’re still not seeing these options, please reach out to our support team here so they can take a deeper look into this for you in accordance with your account. Let me know how this goes!

Thanks, I will contact Support via the link provided. I tried several different browsers - Incognito mode/Chrome (Mac), Firefox (Mac), Safari (Mac), Chrome (Windows), and Edge (Windows) and all showed the same menu.

1 Like