Ubiquity Network Connection Issues

I just upgraded my home network from Amazon Eero mesh, to Ubiquity UniFi. I have a router, two access points, and one extender. Overall, the new network is much faster, stronger, and has broader coverage than my previous Eero network. However, my 3 Ring stick up cams will not connect and operate properly with the new network. They all worked flawlessly on my Eero network. Every other device in the house works much better with the new network. Google search uncovered several blogs and such the indicate the Ring came struggle with multiple access points and a dual 2.4 and 5GHz network. That seems strange as every other device in my house (TVs, Amazon Echos, Laptops, Receivers, phones, iPads, Nintendo, Xbox, etc) all operate much better on the new network. Is there a fix for this?

Hi @Yosh. I was able to find this Community post where another neighbor was asking if Ubiquity worked with Ring. There is a marked solution with links that take you to the Ubiquity forum on how others got it to work with Ring.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.