Two-way talk not working

Hello! I seem to be having issues with the Two-Way talk on my wired in ring doorbell. I’ve tried everything that google has told me to try and nothing has worked! So basically the person standing in front of my camera can hear me but I can’t hear them. I tried rebooting it. Made sure the microphone is enabled. Tried turning my Bluetooth off. Nothing seems to work! Please help :pray:t3:

Hi @AlynaHunt. You also want to make sure you have Audio Recording and Streaming enabled in your Doorbells Privacy Settings. This can be found in your Doorbells Device Settings. If this option is enabled and you are still having the same concern, give our support team a call for further assistance.

Unfortunately Ring will not let you use two-way talk without compromising your family’s privacy. You have to allow audio recordings to be enabled in order to use a feature that should not need audio recording (two-way talk). I just discovered this “feature” and will be returning my Ring shortly to go back to Google’s doorbell, which allows me to disable audio recording but still use two-way live talk. Pretty disappointing!

Hi @Jason44. Your privacy is very important to us. Feel free to visit here to learn more about our Privacy Policy.

Hi Tom, if my privacy was important to Ring, and if my business was important to Ring, then Ring would allow two-way live talk WITHOUT requiring audio recording. Google’s doorbells and others allow this – why doesn’t RING? Ring wants to record my conversations in order to use the live two-way talk feature, which is practically the whole POINT of having a video doorbell. Shame on Ring. I returned my Ring doorbell but still have a security camera (no audio recording enabled). I am using a Google doorbell now and have no audio recording yet I can still talk to visitors at the door through the doorbell.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.