Two Ring doorbells won't connect to home wi-fi

I have two Ring 2nd gen doorbells, one of which suddenly stopped connecting to my home wifi a few months ago. I purchased a second one, thinking maybe my first one stopped working (it was exposed to lots of heat and sun) and it’s having the same issue. When I try to connect either of them, they get stuck at 95% and then fail to connect.

Both doorbells successfully connected to my mobile hotspot (Google Pixel phone). Obviously this is not a long term solution but I was at least able to get the latest updates downloaded on them while they were connected to that. I’ve brought both doorbells inside to get them connected before I try to install them again, they are less than 10 feet from the router.

I have Verizon internet service and the modem is connected in passthrough mode to a TP-Link router, I did not want to use the built-in one Verizon provided me.

I’m a former helpdesk technician so I know my way around a router pretty well. Here is what I’ve tried so far:

  • Changed my SSID to remove punctuation
  • Turned off smart switch 2.4/5GHz
  • Turned off 5GHz completely
  • Changed network security to WPA2 only
  • Turned off 802.11ac/ax on my 5GHz network
  • Changed my 2.4GHz network to 802.11b/g/n only
  • Created a separate IoT network with its own SSID, 2.4GHz only, WPA2 only, still no luck

So I feel like the only difference at this point is the ISP :slight_smile:

Any other suggestions?

Hi @sunshinebattery. Thank you for listing out what you’ve tried so far. However, you’ve already gone through the troubleshooting steps we would have recommended here on the Community. For more in-depth assistance, I’d suggest reaching out to our support team at one of the numbers available here. Your concern may need to be escalated if the regular troubleshooting doesn’t resolve this.

Hi There,

Did you get this resolved? I am having the exact same issue with my Ring doorbell pro gen 1 and Floodlight Gen 1. Both lost connectivity and stall at 95% then says can’t connect to the router. I have other ring devices that will connect and reconnect fine. Just wondering before I call support.

thanks
Bob

Hi Everyone! I am having the same issue at being stuck at 95% when connecting Ring to Wifi. I already tried the below troubleshooting:

  1. Reset the Ring doorbell
  2. Reset the router
  3. Reset the modem
  4. Reset mobile phone
  5. Reinstall Ring app
  6. Connect using other mobile phone

Still the same issue

It’s perfectly working fine before, but I tried to restart it, then cannot connect again.

Please help! :sob:
By the way, I am from Philippines.

Hi @user81191. Where did you buy your Ring device? This problem might be happening because you are using a Ring device in an unsupported region. You can find a list of support regions here. There may be security settings in place on your WiFi network that are blocking your Ring device from joining the WiFi. Try connecting to a mobile hotspot to troubleshoot this.