Two of my devices are showing a registered to someone else

My Ring video doorbell has been playing up so I decided to reinstall it. I have a Ring chime Pro so I first reset that then went to add the doorbell to it. It tells me the device is registered to someone else which is impossible because I’m the only person who has owned it. I tried to request a transfer by sending an email (thinking it would come to me), no such luck. Now I’m stuck with an unusable device and to cap it I’ve just reinstalled my kitchen chime and that says it’s registered to someone else as well. End of my tether, please help.

1 Like

Often these issues are either you bought your devices from a non-Ring reseller or you are trying to use 2 different accounts.
In either case, no one here has access to your account info so you’ll have to contact support. ( Contact Us – Ring Help) Be aware wait times are long and you may have to call a few times until you get someone who can assist.

Well that wasn’t helpful, I bought the devices new from Amazon and have been using them for 3 years with no problem. As for having 2 accounts, I’ve only ever had one, the only thing that’s changed is I got a new modem / hub from VirginMedia.

So did you call Support? If you haven’t then you aren’t going to get your issue solved.

It sounds like you may have setup your Ring device using another account or location in the Ring app. Please double check that you are logging into the owner account, otherwise the Ring app might see that as a previously owned device, even if by yourself. Alternatively, I recommend following our Change of Ownership process.

For further assistance with this, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Same issue with our chime, all setting checks, no account or location changes. Completed whats been advised and still not working. Looking through sites appears to be a common issue with clear guidance or resolution!
Any further advise to fix this RING???