Two Doorbells, two device failures

Ordered a “refurb” Ring Doorbell Pro a week ago (though Amazon). Installation was a breeze. Powered by the Ring Doorbell Power adapter. It worked great or two days and then suddenly lost connection to wi-fi.

Attempts to reconnect failed. It would be stuck at a pulsing white ring. Tried a RESET a few times, and in the few times when the “setup circling light” worked, it failed to connect to the ring app.

Exchanged with Amazon and they sent me another “refurb” unit. Again, setup was a breeze and it worked super… for about 24 hours… and now the exact same problems.

Even removed it and plugged in USB from the side and it GETS to setup mode, but will not set up.

Had I not already purchased a ring Camera (and extra battery), a Ring chime, and the ring power supply, I’d be running away to another brand, but now I’m invested.

Has anyone ELSE had these problems with the Ring Doorbell Pro?
Gregory

Hi there, @GGooden! It sounds like your power is likely sufficient, even when the Doorbell Pro falls offline. During these offline times, if there are still lights showing on the Doorbell Pro, this is a good sign that power is ok. When setting up the Doorbell Pro, or reconnecting, please ensure to choose your 2.4 Ghz wifi connection, rather than 5Ghz.

While it is likely not power related, feel free to go through my Hardwiring Checklist to be sure all steps have been covered. If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.