Two cameras suddenly stuck updating

I have a video doorbell (2nd gen, battery) and a stick up cam (battery). Both worked fine for about a week. Yesterday they both began installing an update automatically. I went to sleep thinking the update process would be finished when I woke up.

The update process never stopped. The stick up cam became non-functional because the battery drained to zero during the update process. I removed the doorbell and tried removing and re-adding the device on my phone (losing all my videos in the process). Every time I re-add the device through the app it becomes stuck in the update process again.

Edit: The camera and doorbell are both working again after removing them and charging the batteries through the USB plug. I am crossing my fingers that another update won’t randomly drain the batteries overnight.

Hi @user21730. I can’t check on the status of your replacement as the Community is a peer-to-peer forum, so I would recommend following up with our support team on that matter specifically. As for your Stick Up Cam, you can reset it after inserting a fully charged battery. To reset your Stick Up Cam, hold down the set up button for at least 20 seconds. Once the reset is complete, set your Camera back up in the Ring app using Set Up a Device. If the Camera still doesn’t complete the update, you will also need to follow up with our support team for that. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

So almost two weeks later I am having the same problem. Doorbell and stick up cam both began automatically updating and became stuck in the update process.

Once again I am going to have to pull out the ladder and press the orange button on the stick up camera. As I type this, the replacement ring doorbell I received has been stuck in the update process for hours. I have tried removing and re-adding the doorbell “device” in the app 3 or 4 times, and it just gets stuck updating every time.

I have the (new replacement) doorbell less than 5 inches away from my wireless router and it has been updating for 30 minutes since I re-added the device another time. The pop-up in the app tells me this process should not take more than 15 minutes.

Update:
So after an hour of the light flashing white, I cut power to the router and the flashing light went off. I turned the router back on and the doorbell cam was suddenly working.

Update 2:
The doorbell decided to update itself again and became stuck. Once again I had to power cycle the router. In the span of 12 hours I have power cycled the router 3 times to get the doorbell out of its endless update loop.

Update 3:
I removed the doorbell “device” from the app and did the factory reset by holding the orange button for 30 seconds. I waited a day without re-adding the “device” in the app. I then re-added the doorbell and the update completed without hiccup. It has now been working for the past 4 or 5 days.

Until the next update…