Turning Off Neighbor Safety Report

@Tom_Ring wrote:

Hi Neighbors. Just wanted to step in and offer these quick steps to see if it improves your experience at all. With the Ring app open, select- Menu > Neighbors > (Gear Icon) > Customize Neighbors. From here you will be able to select what type of reports you see. Additionally, you can tap on Customize Notifications to set a Schedule and then tap on Notification Types to toggle on/off the types of reports you receive notifications for. I have had success with these steps on my iPhone XS. I hope this helps you as well!

If you need additional support, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Except… this does not work. I have this setting set exactly how you indicate it should be, and I STILL get the stupid report every few days. Maybe you should double-check your “solution” before you post it and make sure it is actually a solution. I want exactly 2 notifications from ring: if my doorbell rings or if my alarm goes off. Nothing else. If that cannot be accomplished, I will be cancelling my service and finding alternate soltions.

1 Like

Nope doesn’t work. My notification prefs are off for this, and I just got one. Super annoying there’s no way to turn these off.

1 Like

I have it turned off in every way I can – including the way in your screenshot – and it still sends me these fricken texts. I want it off.

Same here. I have it set to no reports in the one are, then in the area were it asks what kind of reports you want, it won’t let you turn off ALL types. I chose lost pets as the least offensive, but I still get notices for everything.

I am disgusted and want it gone.

OMG, I found the solution. There is a second Ring app called Rapid Ring. It ONLY does the video door bell part–you know, the only part I wanted. You get motion and video alerts from your door bell and only yours. You can see and speak to whoever is at the door and that is it!

Thank god, this was driving me nuts.

1 Like

@AngryNestUser wrote:

Oh, btw, I could probably resell the doorbell and spotlight camera on craigslist, but I don’t want to subject anyone else to this product. It would feel like I’m scamming them, so it’s all going in the trash.

Don’t throw it in the trash, you could be fined from your city. You should properly dispose of it at an Electronic Waste “eWaste” center.

2 months later and still no fix for this? How can there be a way to stop this on android but not IOS?

Easy fix: Get rid of your ring device and delete your account. I’m seriously tempted to do that. I don’t think the developers understand just how vehemently certain people hate notifications. maybe we are in the minority? but I doubt it. Consider that for certain types of mental illness this can be seriously triggering… people in the ADHD / autism spectrum deal differently with distractions, and so take every step necessary to reduce them. One of the only notifications I haven’t figured out how to disable is this stupid Ring one. Great, now I just disable them all, including the doorbell. What a useless product.

There is still no way to turn this off on iOS, the notification isn’t sent on Sundays but seemingly at random, the link to the feature request board @Marley_Ring posted is broken (even though this isn’t a feature request), this has been an issue for months even though there is an option for it in the app.

What is going on with this team? Are y’all under resourced? Are there that many critical bugs that take precedence over this fix for something that’s already implemented?

Hi there, neighbors! The Neighbors Safety Report can indeed be disabled on both Android and IOS devices. While logged in on your Ring app, please try the following steps:

  • Open the Menu (3 lines top left)
  • Select “Neighbors”
  • Tap the gear icon to access your Neighbors Settings
  • Under your neighbors location, select “Customize Neighbors”
  • Scroll to the Advanced Preferences section towards the bottom of this page.
  • Tap Notification Preferences
  • Toggle the Safety Report toggle found on this page.

This should work similarly on both IOS and Android. You will notice various settings and filter options along the way, which can also fine tune your Neighbors experience. Feel free to let us know how this goes! :slight_smile:

After menu there IS NO “neighbor “ setting

Bug Report:
DESCRIPTION: Unfortunately, in iOS, disabling the “Safety Report” toggle switch in “Neighbors > Customize Neighbors > Notification Preferences” does not disable the “Safety Report” notification.

Ring App Version: 5.35.0
iOS version: 14.4

PLEASE ESCALATE THIS BUG FIX – IT IS A PERSISTENT ANNOYANCE THAT IS MAKING ME QUESTION WHETHER RING IS WORTH MY PRECIOUS TIME. SRY FOR ALL CAPS.

Full disclosure --I’m a professor of computer science specializing in software engineering.

I have all notifications turned off in the Neighbors advanced preferences, but still got the safety report today (and every Thursday for the past several months). Why is this?

1 Like

This is the most awful feature! I just spent an hour trying to track down a “shots fired, man loose” notification I got for “nearby.” The map shows the ENTIRE CITY.

So I goodle details. Nothing. I look on Facebook & text with my sheriff friends for my town. Nothing.

USELESS!!!

Allow us to turn these stupid notifications off!!