Trying to Re-Add Ring Doorbell to new Wifi, but 'Device Registered to Someone Else'

Hi all

I’ve got a new wifi, so went to re-install the Ring Doorbell (version 1), but when i scan the QR code, i get ‘This device is registered to someone else’. I’m the registered owner, so i thought i’d ‘Ask for Device Access’ expecting an email. No email.

I think i might have made the mistake of removing the device from the ring app when i couldn’t get it to work ?

I’ve even tried holdinng down the orange reset button for over 20 seconds and re-try the device set up. Same results - ‘The device is registered to someone else’

Any ideas ? What am i doing fundamentally wrong ? Ring support is about as useful as a chocolate teapot and it’s about to become the first ring doorbell in space :slight_smile:

Cheers

1 Like

Make sure you are using the correct Ring account when logging in.

2 Likes

had same problem - then figured out our installer from 3 years ago used my wife’s account!!

1 Like

Thanks both.

The email address could only be 2 and i’ve tried those. Any idea if Ring Support could tell me the email address or is there anywhere i can find it ??

I did the exact same thing :confounded: and still trying to get it set up on my new phone. No luck :roll_eyes:

Hey neighbors. For this concern, I suggest reaching out to our support team. Once you have been verified, there is a security protocol that the support agent can follow to assist you. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.