Trouble using Ring and Nord VPN

What OS are you using on your phone or computer? I’m using iOS 15 on a iPhone 11.

Agreed. I just had the same issue with my S21 Ultra. Stopped working yesterday after major iOS update. It appears Ring (aka Amazon) is trying to gather more data on you. There are only a few apps that do not allow VPNs on my phone which are banking apps… same problem, they want to force you to allow them to collect more data on you. You will note that trying to Login to also will nor work with a VPN on… there lies the true problem with Ring… NOT your VPN. Temporary solution is to disable VPN, login to Ring, then enable VPN and you should get notifications but to view them in the app you have to disable the VPN.

user611 -

When you referred to your S21 Ultra… did you mean to say that it stopped working after a major Android (rather than IOS) update?

If your VPN is turned on are you:

  • Able to display various content on – but not able to display the login screen or
  • Not able to access

I have been using Ring Protect plus for years, and I also use Nord VPN. I have tried switching my vpn connection to NordLynx, and turning local network setting off. But I cannot get the Ring app to work on my iPhone Max Pro 11, using iOS 15.1. If I cannot use the app with my vpn then I will not be renewing my Ring subscription in December.

1 Like

If I had known Ring was not supporting VPN connections I would not have purchased. By disabling my VPN I am making my phone/computer vulnerable.

iOS NordVPN user here too and just noticed the same issue. Ring app will work with VPN if the “Threat Protection” component is turned off.

I had this with other apps, it’s some of the connections in the app that NordVPN classes as adverts.

It’s a shame as Threat Protection is useful on my phone to block annoying adverts when browsing

edit: Whilst testing I noticed that if I turn the VPN off, load the Ring app + start live view and then turn VPN on after the Ring app seems to work with VPN and Threat Proection turned on.

1 Like

I used to have DualVPN’s, and NordLynx as my protocol which prevented my Ring App from launching. Once I removed the DualVPN and selected just one, my Ring App worked without having to push or disconnect. Some of you may have had my same issue “DualVPN’s” for greater security. I’d rather use just 1 VPN and have my Ring App work, than not having it work unless I pause or disconnect my NordVPN just to use my Ring App to access my cameras.

“We also have security measures in place to help protect our neighbors against unauthorized account access, so we do not allow the usage of VPNs at this time.”

This is contradictory to the use of a VPN. VPNs restrict unauthorized access, including RING. It’s your policy to access the user’s IP address and camera/alarm locations due to the neighbor sharing.

My experiences using NORD VPN from my iPhone 13 Plus VS a three year old iPad.

iPhone: I have to either pause or shut off the VPN in order to access the Ring dashboard. No access and I’ve brought this issue up with Ring approximately two years ago, there was a fix. Now the issue is back!

iPad: I have Nord VPN on my iPad and have never had an issue with having to shut off the VPN. “STRANGE”

I contacted Nord during the prior issue and their team was receptive to taking a look into the issue.

Not sure how this is possible when both devices are Apple.

I found the same, except after a few hours reverts back to no access

EXACTLY!!! Nicely stated. This is a Ring issue

What a flop of a product. I’m one year into having a ring door bell, it’s been quaint until I installed a network level nord vpn for mobile devices. Now we can nolonger access ring website or app to see footage.

What happened to the customer comes first motto from the rest of Amazon? Quite clearly there’s plenty of people complaining about this…

Ring needs to pull its finger out and get this fixed…

I personally won’t bother with this company any further.