Trouble connecting to Ring Network

Hello all,
I am hoping someone out there can help me before i throw my camera in the bin.

We recently upgraded our wifi, and ever since i have not been able to connect my camera.

I have followed the steps and each time i get to the stage of connecting to the Ring Network, and it tells me “connection failed”

  • i have tried on multiple devices ( Apple and Android)
  • i have disabled the 5G network on my wifi
  • i have fully charged the battery
  • i have reset the router
  • i have disconnected my phones wifi and reconnected

I am at a loss and reslly hope someone out there can help!

Thanks

This is EXACTLY what is happening to us. We have spent more time on taking the batteries out, putting them in, resetting everything… hours worth of not getting this thing to connect.

Hi neighbors. Which model of Ring Doorbell or Camera do you have? Are you seeing a specific light pattern on the Doorbell or Camera when the wifi connection fails? What is the distance between your Ring device and your wifi router?

Can’t even login from IOS 16 … I am able to login and view my cameras from my Windows Desktop.

Hi @TimothyFS. Is that a specific error message you’re receiving when you try to sign in on the Ring app? It’s also important to note that the Ring app doesn’t support the use of a VPN, and if you have a VPN enabled on your phone, you will likely receive an error message and be unable to login.

I need help connecting to my new Wi-Fi provider

Hi @user23553. You can follow these steps to connect your Video Doorbell or Security Camera to your new wifi network in the Ring App:

  1. Tap on the three lines on the top left
  2. Tap Devices
  3. Select the Doorbell or Security Camera you need to reconnect to wifi—the next screen should be the Device Dashboard
  4. Tap on Device Health
  5. Tap on Change Wifi Network

Remember that wifi passwords are case sensitive. If you don’t know your wifi password, it might be printed on the bottom or side of your router. I hope this helps. :slight_smile:

1 Like

I have a new 3rd gen Ring alarm with doorbell system, everything is working. I have an older 1st Gen Stick Up Cam, it’s fully charged, reset (20s button hold), and I’m able to get its WiFi network to join, then select my home WiFi configuration (same as my other Ring devices), but it always fail to complete the setup when it’s trying to join my home WiFi. I have tried setting my WiFi config security setting to both WPA-1 and WPA-2 but it doesn’t help. I have also restarted my WiFi router, no luck. I can’t seem to find any support docs on this older model of the Stick Up Cam and how to connect it to the current 3rd Gen Ring system.

Hi @linhux. Since you have tried the basic troubleshooting steps, I would recommend, if you are still having the same concern, giving our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support. Our support team should be able to take a more in-depth look at your concern.