Tried everything, stick-up Cameras Won’t connect to my network

My Ring stick-up cams (3 of the same camera) are not connecting to my Wi-Fi network and showing RSSI-0 (In Red). I’ve changed networks, had the Ring sitting on the same desk as my eero router (2023 gen). I’ve reset/restarted my router, my modem, and my device several times, no charge. I even made sure it my router was giving 2.4GHz signal. The RSSI (in red letters) remains at red 0. I’ve followed network troubleshooting, everything is fine but RSSI is still 0 and the devices still won’t connect.

During the setup, I can join the camera’s Wi-Fi, then when I select my network and enter the password to connect, A voice comes over the camera’s speaker and says “now connecting to your Wi-Fi network… this my take a few minutes”, then after about 30-sec the flashing blue light on the camera turns into a flickering green light. Then the voice says, “there is something wrong with your Wi-Fi network, try moving closer the router”. But again, the camera is literally 1 inch from the router and modem.

Please help!

Hi @MrRabbit. Try checking that the ports and protocols used by Ring devices are open on your router. Since all 3 of your Stick Up Cams are not connecting, something may have changed on your network with a recent firmware update. I’d also suggest checking the wifi channel, in case that has changed.

After checking that, you can reset your Cameras by holding down the setup button for 20 seconds. Attempt to walk through a new set up in the Ring app using the steps under Set Up a Device. If the wifi connection still fails, please give our support team a call at one of the numbers available here. You can also get in touch with our support team on Facebook @Ring.

Dont know if you got anywhere with this but I just had the same problem - I managed to sort it and get my devises sorted by turning off the 5GHZ channel of my router during setup. Connected first time that way and now works fine with the 5Ghz channel turned back on.

1 Like

Hi @Ukbass, thanks for sharing the solution that worked for you! :slight_smile: