Tp link deco m4 Fix Yet?

Another post about deco m4 not working with stick cameras. My ring pro doorbell works flawlessly as does my chime.

I have two stick up cameras which I’ve had to resort to enabling WiFi on my virgin super hub 3. Setting to 2GHz only.

I’ve tried every combo of settings on my mesh network (I’m a broadband engineer). I know it’s got to be firmware related as doorbell works fine. I’ve read a few posts of people complaining but has anyone had an update from ring?

My mesh signal reaches the bottom of my garden yet I’ve had to install a netgear powerline adapter just to get one of the cameras to get a decent signal as my hub 3 is too far away.

Thank you for sharing your experience with the Community, @TFG! When you mention your Stick Up Cams not operating properly with your mesh network, what are the symptoms you are observing with your Cam? I’ll be happy to assist further. :slight_smile:

Hi. The issue is nothing works once connected to it. Yet works fine when connected to my ISP router. Says WiFi signal is fine showing RSSI-40 on both cameras. Health check passes. However live view doesn’t work. It doesn’t pick up motion. Basically does nothing.

1 Like

I’m seeing exactly the same issue - 2 stick up cams, tp-link m4 wifi. Great signal strength - no live view, no detections, no alerts most of the time. One of my stick up cameras (plug-in) allows the live view sometimes, but mostly not. A hard power cycle brings it back online briefly, then it’s unavailable again.

The rear stick-up cam (battery/solar powered) is also online intermittently. Live view is never available.

I’ve set the wifi network to 2.4ghz only and disabled MESH for both stick-up cams.

Help please?

Hi neighbors! If your signal strength is showing as sufficient, or the Camera is operating as intended when connected to another network, the best first step here will be to check network settings.

Neighbors have shared in the past the Tplink deco m4 has a feature called fast roaming. This is worth testing to see if it might be causing this concern. Please also check out our help center article about ports and protocols as it may help with video and communications.

While the signal strength may look sufficient in the Ring app, it is always good to ensure that any mesh access points connecting to this Camera are within reasonable proximity. If your network has the option, dedicating or prioritizing your Ring device on an access point or, the network in general, could also help. Feel free to let us know how this goes! :slight_smile:

i’ve tried most/all of the suggestions in the help documents referenced, including disabling “fast roaming”, as documented in this post. At this point, is there a list of supported wifi mesh hardware out there? i.e. is the tp-link deco m5 supported?

Thanks,

Matt.

Good question @mmatt! We will often make note of our device requirements so neighbors can obtain the intended operation. This can be found on product information articles in our help center, or even on the product purchase page at Ring.com. Our Stick Up Cam technical specifications, for example, has a power and connectivity section which lists out the wifi connection compliance. For most or all of our devices you will see “802.11 b/g/n Wi-Fi connection @ 2.4GHz” is the requirements for obtaining a proper connection.

That being said, resources can vary as can network types and features available. If you router meets these standards but is unique in operation or is not working as intended, our support team is happy to help with in-depth troubleshooting. We also offer Eero solutions at Ring.com.

My routers (tp-link deco m4) support all the requirements posted on the RING site. As noted, i went through all troubleshooting steps and have no clear solution.

Through monitoring for the last week, it seems one reason the Ring devices lose connectivity after the routers change from busy channels to quieter channels (they auto update channels to improve wifi signals). The stickup cams seem to not handle this scenario at all, and currently (24hrs after my routers switched channels), still have not reconnected to wifi.

This is a common feature for modern routers - automatically switching channels. Even the eero does it.